How to prevent X1 from indexing XML

You've got questions? We think we have some answers!

Moderator: Mods

How to prevent X1 from indexing XML

Postby edsager » Sun Oct 02, 2011 11:33 pm

Hello All,

I am using X1 Pro v. 6.7.3 on a Windows 7-64-bit machine.

I do not want X1 to index XML files--neither the contents nor the file info in general.

I de-selected the XML extension in the Options section of X1, conducted a search, and typed the word, "Indexed" in the "Flags" column.

The "Flags" column indicates a number of XML files were indexed and the column titled, "Indexing Status" shows either "Stellant OK" or "Stellant NOFILTER IFilter OK[.]"

My index contains about 1.1 million entries with 750,000 files currently indexed, so I am trying to limit the number of files indexed. Eliminating the XML files would help.

Potential problem: some of the files being indexed have saved their text as an XML file.

Is there a way to prevent X1 from indexing XML files?

Thank you,
edsager
edsager
 
Posts: 19
Joined: Wed Mar 26, 2008 1:19 pm

Re: How to prevent X1 from indexing XML

Postby Kenward » Mon Oct 03, 2011 1:42 am

I assume that you mean that you have deselected .XML in the "Specify File Types" section.

If so, and if you have just done this, then it may take some time for X1 to "forget" these files, especially with "1.1 million entries".
MK
X1 Search 8.6.1 - Build 6003fa (64-bit)
Windows 10 Pro 64-bit | Windows 10 Home 32-bit
No, I have nothing to do with X1, just a user since 2004.
Kenward
X1 Guru
X1 Guru
 
Posts: 4149
Joined: Tue Apr 20, 2004 2:35 am
Location: UK

Re: How to prevent X1 from indexing XML

Postby edsager » Mon Oct 03, 2011 2:29 pm

Dear Kenward:

Thank you for your reply.

Your assumption of where in the Options Menu I de-selected the XML extension is correct.

However, I did not do this recently; rather it was done when I first installed X1 a few months ago.

About 2 months ago, I selected the XML extension, allowed X1 to start indexing, then stopped the indexing, de-selected XML extension again, deleted the index, and allowed X1 to re-index en totale. Not exactly sure why I did this. I have deleted the index and had X1 re-index files at least twice since then.

XML files have always been and still are indexed for content.

Any other suggestions?

Thank you,
edsager
edsager
 
Posts: 19
Joined: Wed Mar 26, 2008 1:19 pm

Re: How to prevent X1 from indexing XML

Postby edsager » Tue Oct 02, 2012 2:13 pm

This is an old thread started by me, but I am still wondering how to get X1 to stop indexing XML file types.

X1 indicates that 3,138,956 items indexed. I know that at least 600,000 of the items indexed are XML files.

I am now using X1 Pro 7 Beta v.4320kg.

Any ideas?

Thank you,
edsager
edsager
 
Posts: 19
Joined: Wed Mar 26, 2008 1:19 pm

Re: How to prevent X1 from indexing XML

Postby Kenward » Wed Oct 03, 2012 1:30 am

If you have deselected xml in the file types, have you also chosen the locations that you index so that it eliminates as many of these files as possible?

xml files are often associated with programs and their settings. These are rarely places where you would look for work files of the sort that demand X1's attention. So, I do not ask X1 to index anything in "Programs", "Windows" and similar places.

Indeed, I maintain a document regime that keeps as much as possible on a separate "Data" drive with all of my work and research material. These I exclude from X1. Where something does maintain a mixture of documents and related "junk" I tell it to only index "File names and sizes, plus content for specified extensions..." This may mean that X1 will remember that there are xml files in those places, but it will not index their content.
MK
X1 Search 8.6.1 - Build 6003fa (64-bit)
Windows 10 Pro 64-bit | Windows 10 Home 32-bit
No, I have nothing to do with X1, just a user since 2004.
Kenward
X1 Guru
X1 Guru
 
Posts: 4149
Joined: Tue Apr 20, 2004 2:35 am
Location: UK

Re: How to prevent X1 from indexing XML

Postby Chris Wheaton » Wed Oct 03, 2012 10:50 am

Ed - Kenward's advice is about as good as it gets.

XML files are among our default file types to index. If an XML file exists in a directory you have asked X1 to index, there is no way to stop X1 from indexing that file.

But you can disable XML files from our list of files that are indexed for content. X1 will still index the file type, but will only index metadata areas.

And as Kenward has stated - if you can somehow corral your XML files to a single folder - you can configure X1 to not index that folder at all or set it to index that folder for File names and Sizes only; which still leaves it available to search on those occasions that may call for a search of XML files.
Sincerely,

Chris Wheaton
Technical Support
Customer Care Rep.
______________________

www.X1.com
Chris Wheaton
X1 Rep
X1 Rep
 
Posts: 301
Joined: Tue Dec 23, 2008 1:00 pm
Location: Pasadena, CA

Re: How to prevent X1 from indexing XML

Postby edsager » Mon Jul 22, 2013 9:19 pm

I never did say thank you to both Kenward and Chris Wheaton.

Thank you for your replies!

edsager
edsager
 
Posts: 19
Joined: Wed Mar 26, 2008 1:19 pm


Return to Questions and Answers

Who is online

Users browsing this forum: Google [Bot] and 123 guests

cron