Page 1 of 1

Can automatic selection of the first result be turned off?

PostPosted: Wed Dec 12, 2007 10:34 pm
by ofofofofof
When X1 is first installed, the Preview pane displays a graphic until a specific result is selected. There is also an option to never show that again. Having now done that, X1 automatically selects the first result. (At least that's what seemed to have happened.)

Is it possible to turn off that auto selection?

If not, is it possible to turn on the display of that graphic again (I’ve looked but find no ref to this).

I think I'd prefer to have the Preview simply go blank on completion of a new search, until something is actually selected. At least as an option.

PostPosted: Thu Dec 13, 2007 1:18 am
by w0qj
Well, I believe what you are asking is,

==>Can we turn off finding search results "As Fast As You Type" feature for local data.
[Technical Note: If X1 can turn off this feature for local data searches, then there should be no 'preview delay' that some are saying is still there].

(Again, we've moved your posting to the Feature Request Forum. Thanks again for your suggestion!)

PostPosted: Thu Dec 13, 2007 2:11 am
by ofofofofof
I must not have been clear in what I was saying. I'm not complaining about the "As Fast As You Type" feature. The fact that the results start listing immediately is fantastic.

I was talking about how X1 jumps to the first result in the results list, which selects it, and which then automatically displays it in the Preview pane (when the Preview is opened, of course.)

The issue isn't the speed the results are listed, but the automatic selection of the first result in the list.

I would like the option to look through the results list and manually select the first file I see previewed, in effect, to not have X1 pre-select which file to show me, which is always whichever one happens to be at the top of the list, which may not be the one I'm actually interested in.

PostPosted: Thu Dec 13, 2007 3:39 am
by Kenward
Would a solution be to get back the "first use" view?

If so, that issue came up here not long ago. A search might find it.

PostPosted: Thu Dec 13, 2007 11:41 am
by Greg Dawes

While you cannot get this back using the main X1 UI, you can achieve the result by editing an INI file.

This post describes the solution:

Basically, you need to:

1. Close X1 using File > Exit (don't close using the "X" in the upper, right corner)
2. Edit the X1Config.ini file
(This file resides in your X1 index directory - normally located at C:\Documents and Settings\<username>\Local Settings\Application Data\X1 Desktop Search\)
3. In the [General] section, delete this line: JSDontShowAgain=10
4. Save and Close the X1Config.ini file
5. Relaunch X1

This should bring back the default X1 graphic until a result is selected.

PostPosted: Thu Dec 13, 2007 5:05 pm
by Greg Dawes
Sorry pgk,

I don't mean to ignore you, ofofofofof course. In fact, I've already submitted a feature request for this; just forgot to include this bit of information.