Failed Installation

X1 ® Professional Client Version 6.6

Moderator: Mods

Failed Installation

Postby hilbert42 » Tue Feb 10, 2015 2:03 pm

Tried two separate attempts to demo latest X1 but it failed. After successful user ID and downloader, the convoluted downloading and installation failed--the only suggested help being this forum.

No, it's not my machine. As a consequence of X1's failure to install, I downloaded the latest Copernic Desktop Search which installed without fuss in the normal manner and it's working properly! Sorry, looks again like you've lost a sale.

Frankly, I'm fed up with troublesome programs that fail to do what they're supposed to. X1 used to install without effort, now it doesn't. And that's your problem, not mine.

Not happy.
hilbert42
 
Posts: 3
Joined: Tue Feb 10, 2015 1:36 pm

Re: Failed Installation

Postby Kenward » Tue Feb 10, 2015 2:41 pm

Is there any reason why you have posted this message in the area reserved for a "long dead" version of X1?

Are you really trying to install X1 Professional Client 6.6?
MK
X1 Search 8.5.2 - Build 6001si (64-bit)
Windows 10 Pro 64-bit | Windows 10 Home 32-bit
No, I have nothing to do with X1, just a user since 2004.
Kenward
X1 Guru
X1 Guru
 
Posts: 4068
Joined: Tue Apr 20, 2004 2:35 am
Location: UK

Re: Failed Installation

Postby hilbert42 » Tue Feb 10, 2015 5:19 pm

Reasons herewith:

1. I'm new to this board.

2. It's certainly not clear where the message should have been posted. After all, you're using a [free software I recall!] phpBB board which, through design, [all] have notoriously bad ergonomics, with their all-the-same drab look, no hierarchical indenting and lack of graphical identification markers, indexes etc. Whenever I encounter a phpBB board I know I've struck a time/finding things problem. I simply don't have the time to muck about.

3. Remember, X1 in its dying breath, referred me to this board and that's why I'm here now. If your/X1's coders had coded the 'death message' correctly then there'd have been no confusion--the links would have landed me in exactly the correct spot, touché.

4. Moreover, I should NOT have to register (to this board) just to follow this so-called 'help' from the dying demo program. It's bad enough (and time-wasting) to even have to register JUST for a 14-day demo--come on!! And, in the circumstances, it really does look pretty unprofessional/amateurish to be referred to some 'vague' unhelpful location, especially given that X1 is supposedly a mature and 'professional' program. (The questions that immediately come to mind are what have the coders been doing all these years, and how good are the program's internals behind the gloss and obfuscation through compilation).

May I suggest you refer this post to them for future action.

5. X1 doesn't help by essentially hiding its version numbers (they're not clear--in the same way by looking at the web site that it's NOT possible (at least quickly) to determine what product does what. For example, where are the detailed spec sheets explaining all technical details, file type scanned etc. (so they can be compared to other similar products)?

6. How am I supposed to know the current version number when X1 died before it could tell me? There is an assumption here that everyone is already following the product's development moment by moment--no so! I'm not new to X1, I first used it about 10 years ago but it fell into disuse when machines died. The most recent versions I still have here in the archive (not used) are "X1_Enterprise_Client_5.6.1_build_3377-setup.exe" and "X1_Enterprise_Client_5.6.3_build_3453_x1-setup.exe", so how on earth am I supposed to know that version 6.6 is already ancient history?

Perhaps, also, you should refer this post your marketing department (seems they need it).

BTW, the reason X1 was an issue here is that clients of mine wanted advice on what the best local search engine for their operation and, as a consequence of the X1's failure, I've just advised them to run with Copernic (as I don't want to be the consultant landed/blamed for future installation failures/additional software maintenance costs, etc.). This is not the first time I've experienced such problems either. I recall around 2010-11 having a similar problem with another client when we couldn't do an X1 offline installation. Seems X1 has so much business it doesn't have to worry about 'little' problems such as that.
hilbert42
 
Posts: 3
Joined: Tue Feb 10, 2015 1:36 pm

Re: Failed Installation

Postby Kenward » Wed Feb 11, 2015 3:06 am

hilbert42 wrote:Perhaps, also, you should refer this post your marketing department (seems they need it).


I don't have a marketing department. But I know a good optician who might provide you with some spectacles so that you can read what it says in my signature.

Then you might be also able to read the front page of the bulletin board where it lists the various versions of X1, so that you find the right place to post your question. (I agree about the cheapskate use of free bulletin-board technology but have come across truly dreadful commercial systems out there.)

I will leave it for the people who work for X1 to decide whether or not to deal with your technical issues, if there are any in that long rant.
MK
X1 Search 8.5.2 - Build 6001si (64-bit)
Windows 10 Pro 64-bit | Windows 10 Home 32-bit
No, I have nothing to do with X1, just a user since 2004.
Kenward
X1 Guru
X1 Guru
 
Posts: 4068
Joined: Tue Apr 20, 2004 2:35 am
Location: UK

Re: Failed Installation

Postby hilbert42 » Wed Feb 11, 2015 7:32 am

"...but have come across truly dreadful commercial systems out there"

Agreed, many are much worse!
hilbert42
 
Posts: 3
Joined: Tue Feb 10, 2015 1:36 pm

Re: Failed Installation

Postby Kenward » Wed Feb 11, 2015 9:12 am

hilbert42 wrote:"...but have come across truly dreadful commercial systems out there"

Agreed, many are much worse!

Think Lithium.
MK
X1 Search 8.5.2 - Build 6001si (64-bit)
Windows 10 Pro 64-bit | Windows 10 Home 32-bit
No, I have nothing to do with X1, just a user since 2004.
Kenward
X1 Guru
X1 Guru
 
Posts: 4068
Joined: Tue Apr 20, 2004 2:35 am
Location: UK


Return to X1 Professional Client 6.6

Who is online

Users browsing this forum: No registered users and 5 guests