X1 not starting up

X1 ® Professional Client Version 6.6

Moderator: Mods

X1 not starting up

Postby robhirsch » Fri May 22, 2015 10:57 am

Suddenly my X1 appears to start and run, but the UI never initializes.

I tried uninstalling and reinstalling - no help.

Ideas?
Rob
robhirsch
 
Posts: 3
Joined: Fri May 22, 2015 10:34 am

Re: X1 not starting up

Postby Kenward » Sat May 23, 2015 8:23 am

Any chance that it is launching but with the Window off screen?

I have seen that in the past.

Unlikely if you don't see it in the Task Bar, but worth investigating.
MK
X1 Search 8.5.2 - Build 6001si (64-bit)
Windows 10 Pro 64-bit | Windows 10 Home 32-bit
No, I have nothing to do with X1, just a user since 2004.
Kenward
X1 Guru
X1 Guru
 
Posts: 4068
Joined: Tue Apr 20, 2004 2:35 am
Location: UK

Re: X1 not starting up

Postby robhirsch » Mon May 25, 2015 7:11 pm

That was it!
Thanks!...i forgot about that option then tried the Alt-Spacebar trick to get the "move" menu and able to drag it to reality.

Thanks
Rob
robhirsch
 
Posts: 3
Joined: Fri May 22, 2015 10:34 am

Re: X1 not starting up

Postby robhirsch » Wed May 27, 2015 6:48 am

any idea how to "fix" this so it doesn't keep ending off screen. I continually have to do the trick.
robhirsch
 
Posts: 3
Joined: Fri May 22, 2015 10:34 am

Re: X1 not starting up

Postby Kenward » Wed May 27, 2015 7:14 am

You could try closing X1 with the Shift+Close trick. This is supposed to force X1 to write its configuration before closing.

Or maybe even just completely close X1 before you shut down your PC. This ensures that the files are written before Windows completes its own shutdown.

In earlier versions of X1, I knew where it wrote the screen position data so I could go and delete it. I'm afraid I can't see where they keep that data now. They probably moved it into an xml file rather than the original ini file.

Perhaps it is in the file UIConfig.xml.

Among other screen data, it holds stuff like:

<MainWindowW>1410</MainWindowW>
<MainWindowH>964</MainWindowH>

In your shoes I would try the first ideas. If they fail, then close X1 and rename the file UIConfig.xml to something like UIConfig.xml.old. Then X1 will recreate that file when it next starts. If that fails then you can recover that file.
MK
X1 Search 8.5.2 - Build 6001si (64-bit)
Windows 10 Pro 64-bit | Windows 10 Home 32-bit
No, I have nothing to do with X1, just a user since 2004.
Kenward
X1 Guru
X1 Guru
 
Posts: 4068
Joined: Tue Apr 20, 2004 2:35 am
Location: UK


Return to X1 Professional Client 6.6

Who is online

Users browsing this forum: No registered users and 4 guests