Anyone worked out how to recover vanishing X1?

X1® Professional Client Version - Raptor builds (both Beta and Release Candidates)

Moderator: Mods

Anyone worked out how to recover vanishing X1?

Postby Kenward » Mon Jan 17, 2011 10:42 am

For reasons that are not at all clear to me, once again X1 is into "vanishing screen" mode.

Enough people have reported this – here is one long discussion that X1 seems to have ignored and here is another one, also devoid of any X1 feedback – to make it unnecessary to explain it yet again, but here goes.

You launch X1. It heaves into view. Hangs around for a few seconds and then goes away.

After that, nothing can bring it back to life.

I don't know if it is related, but X1 also fails to respond in the Notification area (System tray). Takes minutes for anything to appear.

While this is happening, "X1 Service" runs at 80-90% of CPU power.

If I kill X1 in Task Manager, it tries to start and then goes away again, taking "X1 Service" with it.

This happens to me every few weeks.

Several reports here: no response from X1 that I have seen. Has anyone raised this officially?

Things that do not work:

  • Rename x1.ini (Same behaviour after you try this.)
  • Rename X1IndexService.ini (Same behaviour after you try this.)
  • Rename seaved searches folder
  • Rename all-schema.xml
  • Rename favtree.xml
  • Rename alltag-schema.xml
  • Rename searchestree.xml
  • Rename searchhistory.xml
  • Rename searchtoolbar.xml
  • "Repair" X1

It is hard to think of anything else I can try.

The regularity of this behaviour is disheartening. I really do not want to have to reindex my files every few weeks.
MK
X1 Search 8.5.2 - Build 6001si (64-bit)
Windows 10 Pro 64-bit | Windows 10 Home 32-bit
No, I have nothing to do with X1, just a user since 2004.
Kenward
X1 Guru
X1 Guru
 
Posts: 4107
Joined: Tue Apr 20, 2004 2:35 am
Location: UK

Re: Anyone worked out how to recover vanishing X1?

Postby Kenward » Mon Jan 17, 2011 11:09 am

Another thing that has no effect.

Repair main PST in Outlook.
MK
X1 Search 8.5.2 - Build 6001si (64-bit)
Windows 10 Pro 64-bit | Windows 10 Home 32-bit
No, I have nothing to do with X1, just a user since 2004.
Kenward
X1 Guru
X1 Guru
 
Posts: 4107
Joined: Tue Apr 20, 2004 2:35 am
Location: UK

Re: Anyone worked out how to recover vanishing X1?

Postby askwong » Mon Jan 17, 2011 12:22 pm

I've also had similar experiences with X1 before...

I ended up having to uninstalling X1 (do not keep user settings), and install latest stable version of X1.

My current version of X1 is: 6.7.2 (Build 4054by) which does not have this problem.

I'm sure Kenward is very experienced in X1, but i'm just posting this stable version (for Win7 32-bit) for other users' reference.
askwong
X1 Super User
X1 Super User
 
Posts: 113
Joined: Mon May 22, 2006 11:29 pm

Re: Anyone worked out how to recover vanishing X1?

Postby Kenward » Mon Jan 17, 2011 2:50 pm

In the end, I did not need to uninstall/reinstall. I wiped the index. (That's two days when I will not be able to work properly.)

But that was not the end of it. I still got crashes with the "index free" version.

At least it showed crash messages then. But they didn't mean anything.

I then did a repair. I am now back to square one with no index, and the need to rebuild all my "Favorite Searches".

This latter task would be easier if X1 actually managed to allow the usual drag-and-drop manoeuvres.

Drag and drop is broken. Always has been. You can drag only into visible folders. Most software will scroll up into higher invisible levels. Not X1.

Get it wrong and drag and drop also dumps something you want to move at the bottom of the pile. It does not seem to be possible to put an item at the lowest level in a folder that already contains several items.

Create a new folder and you end up having to do things that simply are not necessary with most software. Normally, you create a new folder and the cursor sits there inviting you to change the name. Some hopes.

Once again, this has been reported before. No response. Not even a recognition that it is broken. Or, advice on how to make it work if it isn't broken.

I haven't even looked at my various saved RSS searches. These usually fall apart every time I sneeze.

There are just so many things wrong with the X1 interface. Most of them reported in the past. Never fixed or even acknowledged.

In general, X1 breaks oh so many of the Windows rules. Not to mention conventions on usability.

I wouldn't matter if we didn't get these meltdowns every few weeks. But software with these defects really needs escape routes.

What we need urgently is a utility to check and mend broken indexes. We also need a way to save the current configuration, which a dead index should not kill, so that the recovery task does not take days.

Better still would be software that does not blow up every time someone in Outer Mongolia breaks wind.

I guess this is one consequence of "enterprise" software. X1 doesn't get to see every catastrophe at the desktop. That lands in the lap of some poor IT manager. But they don't turn up here with their tales of doom and gloom.

Software that purports to work with Windows and that aims at the consumer really needs to be software that works with Windows and that aims at the consumer. After all, that is exactly what the competition does, even if it is not suited to the corporate environment.

I wonder how many other people would persevere with these travails?
MK
X1 Search 8.5.2 - Build 6001si (64-bit)
Windows 10 Pro 64-bit | Windows 10 Home 32-bit
No, I have nothing to do with X1, just a user since 2004.
Kenward
X1 Guru
X1 Guru
 
Posts: 4107
Joined: Tue Apr 20, 2004 2:35 am
Location: UK

Re: Anyone worked out how to recover vanishing X1?

Postby tjh » Mon Jan 17, 2011 4:28 pm

Kenward wrote:...and the need to rebuild all my "Favorite Searches".

I realise this doesn't help you now, but I back mine up on a semi-regular basis just in case I have issues.
TiM
X1 Search v8.5.1 - 6001se (64 Bit)
tjh
X1 Super User
X1 Super User
 
Posts: 400
Joined: Sat Apr 12, 2008 4:12 am
Location: Napier, New Zealand

Re: Anyone worked out how to recover vanishing X1?

Postby Kenward » Tue Jan 18, 2011 2:35 am

tjh wrote:
Kenward wrote:...and the need to rebuild all my "Favorite Searches".

I realise this doesn't help you now, but I back mine up on a semi-regular basis just in case I have issues.

I should have been clearer.

I do preserve the searches, but the order and nesting within the "All Searches" pane are harder to understand.

With next to no official guidance, I have been trying to work out which of x1's xml files it is safe to backup and restore.

This is the set I have:

all-schema.xml
allann-schema.xml
alltag-schema.xml
favtree.xml
searchestree.xml
searchhistory.xml
searchtoolbar.xml

I need to work out which each does. Some are obvious by their names.

It should even be possible to edit them manually,m which would be quicker than the badly implemented drag and drop regime that x1 uses.

The real puzzler for me is all those rsstablefed*-schema.xml things.

I want to be able to recover my configured RSS feeds after a crash.
MK
X1 Search 8.5.2 - Build 6001si (64-bit)
Windows 10 Pro 64-bit | Windows 10 Home 32-bit
No, I have nothing to do with X1, just a user since 2004.
Kenward
X1 Guru
X1 Guru
 
Posts: 4107
Joined: Tue Apr 20, 2004 2:35 am
Location: UK

Re: Anyone worked out how to recover vanishing X1?

Postby Greg Dawes » Wed Jan 19, 2011 6:01 pm

We have responded, outside of the forums, to Kenward and have resolved his immediate problem of not being able to successfully launch. We'll have more to share on this in the next several days.
Greg Dawes
QA Engineer
X1 Technologies
http://www.x1.com/company/contact-us
Greg Dawes
X1 Rep
X1 Rep
 
Posts: 638
Joined: Thu Jul 07, 2005 9:46 am
Location: Pasadena, CA

Re: Anyone worked out how to recover vanishing X1?

Postby Kenward » Thu Jan 20, 2011 3:00 am

Greg Dawes wrote:We have responded, outside of the forums, to Kenward and have resolved his immediate problem of not being able to successfully launch.

Up to a point Lord Copper. The resolution came when I used x1's index zapper to erase the index and start again from scratch.

So, until we have something else to throw at the problem, watch this space, my advice to anyone hit by this one is to track down the index deletion tool and use it.

http://www.x1.com/cs/x1_index_deletion_tool.exe
MK
X1 Search 8.5.2 - Build 6001si (64-bit)
Windows 10 Pro 64-bit | Windows 10 Home 32-bit
No, I have nothing to do with X1, just a user since 2004.
Kenward
X1 Guru
X1 Guru
 
Posts: 4107
Joined: Tue Apr 20, 2004 2:35 am
Location: UK

Re: Anyone worked out how to recover vanishing X1?

Postby johnrellis5 » Tue Feb 01, 2011 12:28 pm

My X1 Pro Client 6.7.2 (Windows 7 64-bit) just started getting similar symptoms, after many months of usage -- the X1 window would briefly appear for a few seconds and then disappear, before I could do anything. The X1.exe and X1Service.exe processes would also go away.

Deleting the indexes appears to have solved the problem. Rebooting, repair-install, and rebooting did not solve the problem.

I found the file c:\users\ellis\appdata\local\x1 destkop search\servcrash.log, containing this:

********************
LogID: 1013357925
Version: 4054by Date: 2/01/2011 10:40:42 AM
X1Service: 00401000
CWSortArray index out of bounds (-1)
Exception Address: 00490B65
Stack: 00490B60 00490BE9 005ACC4D 005AD071 005ADBE4 00474D62 00474DDA 00435063 0044E0A4 00542E5F 00542E74 00402A5C 004032A5 00403636 00543442 00406FD1 0043994E 00410BFA 004358BC 00435A41 00435A85 004351F2 005E02A3 005E1836
Automatically generated description:

---End description
-------- Specs --------
Windows 7 Workstation Service Pack:
Intel Celeron 2133MHz
131 processes active
Virtual Memory: 1864M Free / 2048M Total
Physical Memory: 4096M Free / 4096M Total
Data drive: 94794M Free / 465738M Total
Outlook Version: 14.0.4760.1000
MAPI DLL: mapi32.dll (actual: OLMAPI32.DLL); Version: 14.0.4760.1000
-------- INI File --------
INI file information is suppressed

********************
johnrellis5
 
Posts: 5
Joined: Tue Feb 01, 2011 12:08 pm

Re: Anyone worked out how to recover vanishing X1?

Postby Kenward » Tue Feb 01, 2011 2:45 pm

Yup delete index and start again. Sigh.

We were promised something else on this front.

Next time you see this behaviour, send an official support request.
MK
X1 Search 8.5.2 - Build 6001si (64-bit)
Windows 10 Pro 64-bit | Windows 10 Home 32-bit
No, I have nothing to do with X1, just a user since 2004.
Kenward
X1 Guru
X1 Guru
 
Posts: 4107
Joined: Tue Apr 20, 2004 2:35 am
Location: UK

Re: Anyone worked out how to recover vanishing X1?

Postby brasselv » Tue Feb 01, 2011 3:38 pm

Yup, +1
Having had this very same problem for a long time now.
Every few weeks, I just wipe the index and rebuild. : (
brasselv
 
Posts: 1
Joined: Fri Jan 21, 2011 4:51 am

Re: Anyone worked out how to recover vanishing X1?

Postby Greg Dawes » Wed Feb 02, 2011 8:38 am

johnrellis5,

We believe that this error is an indication of a problem with the integrity of your X1 index files. The next time you experience the CWSortArray index out of bounds (-1) error (as shown in the servcrash.log file), try running the following steps:


If this fix works for you, in an effort to determine the cause of the index corruption, please let us know if your computer recently crashed or shut down unexpectedly?

Oh, and we have had a few (not very many) users tell us that they had to run the tool twice before X1 would launch successfully.

We hope that this works for you.
Greg Dawes
QA Engineer
X1 Technologies
http://www.x1.com/company/contact-us
Greg Dawes
X1 Rep
X1 Rep
 
Posts: 638
Joined: Thu Jul 07, 2005 9:46 am
Location: Pasadena, CA

Re: Anyone worked out how to recover vanishing X1?

Postby Kenward » Wed Feb 02, 2011 3:45 pm

Would you know it? Away from home at the moment, I asked my laptop to launch x1.

Poof. Started and stopped.

Ran the repair tool.

Started. Magic. Back in business immediately.

The one difference between this and my home machine is that this one indexes a USB drive that I use to carry important research files. Stuff that won't fit on the laptop.
MK
X1 Search 8.5.2 - Build 6001si (64-bit)
Windows 10 Pro 64-bit | Windows 10 Home 32-bit
No, I have nothing to do with X1, just a user since 2004.
Kenward
X1 Guru
X1 Guru
 
Posts: 4107
Joined: Tue Apr 20, 2004 2:35 am
Location: UK

Re: Anyone worked out how to recover vanishing X1?

Postby tjh » Wed Feb 02, 2011 4:04 pm

Kenward wrote:Would you know it? Away from home at the moment, I asked my laptop to launch x1.

Poof. Started and stopped.

Ran the repair tool.

Started. Magic. Back in business immediately.


Awesome. This is really great news. I've never been bitten by this bug (I leave my work PC on all the time) but if I am, it's good to know this exists.
TiM
X1 Search v8.5.1 - 6001se (64 Bit)
tjh
X1 Super User
X1 Super User
 
Posts: 400
Joined: Sat Apr 12, 2008 4:12 am
Location: Napier, New Zealand

Re: Anyone worked out how to recover vanishing X1?

Postby arehm » Wed Feb 09, 2011 9:06 am

Fixed it for me too.Phew.
arehm
 
Posts: 40
Joined: Fri Apr 17, 2009 5:16 am

Re: Anyone worked out how to recover vanishing X1?

Postby JBreault » Mon Feb 14, 2011 8:11 pm

My Win 7 32 bit with x1 running lost power and shut off. When I restarted x1 after powering up, x1 screen would come up for a moment and then puff - off. By using both the delete and repair tool referred to above and copied here (for ease of use by others), this fixed the problem. I ran the repair tool twice.

I did uninstall x1 and I delete the x1 directory under program files, which I probably didn't have to do. Thanks x1!

Step 1:
1. Download this file: http://www.x1.com/cs/x1_index_repair_tool.exe
2. Double-click the downloaded EXE to run
3. You will be provided with a warning message, respond "Yes"
4. After running the tool, launch X1

If this doesn't work, delete the index but you will have to rebuild it:

Step 2:

1, Download this: http://www.x1.com/cs/x1_index_deletion_tool.exe
2. Double-click the downloaded EXE to run
JBreault
 
Posts: 26
Joined: Sat Jul 03, 2004 6:17 pm

Re: Anyone worked out how to recover vanishing X1?

Postby Kenward » Tue Feb 15, 2011 3:02 am

My first step in this situation would be to use only the repair tool.

In that way you may be able to rescue your index. Other strategies may force a complete reindex.

Go on to other stages only if you find that an index repair does not solve your problem.
MK
X1 Search 8.5.2 - Build 6001si (64-bit)
Windows 10 Pro 64-bit | Windows 10 Home 32-bit
No, I have nothing to do with X1, just a user since 2004.
Kenward
X1 Guru
X1 Guru
 
Posts: 4107
Joined: Tue Apr 20, 2004 2:35 am
Location: UK

Re: Anyone worked out how to recover vanishing X1?

Postby Kenward » Tue Feb 22, 2011 6:27 am

If anyone lands here expecting the Index Repair tool to fix all their problems. Be prepared for a disappointment.

It does not always work.

I now have X1 coming into view, hanging around for a few seconds, and the performing its usual vanishing trick.

And that is after a couple of repair runs.
MK
X1 Search 8.5.2 - Build 6001si (64-bit)
Windows 10 Pro 64-bit | Windows 10 Home 32-bit
No, I have nothing to do with X1, just a user since 2004.
Kenward
X1 Guru
X1 Guru
 
Posts: 4107
Joined: Tue Apr 20, 2004 2:35 am
Location: UK

Re: Anyone worked out how to recover vanishing X1?

Postby FRB » Sun Feb 27, 2011 3:39 pm

Kenward wrote:Software that purports to work with Windows and that aims at the consumer really needs to be software that works with Windows and that aims at the consumer. After all, that is exactly what the competition does, even if it is not suited to the corporate environment.

I wonder how many other people would persevere with these travails?



Yeah, what he said.

It's obviously a corrupt index issue as deleting the indexes fixes this. They even have a tool for this specific purpose (x1_index_deletion_tool). Sooooo....They have a problem with corrupting their own indexes. If they are trying to maintain their own db, it obviously isn't working. Maybe they should switch to some open source db. I poked around in the install dir and didn't see anything obvious that points to what db they are using. There is a reference to their use of a Notes/Delphi class library in the "About X1" so I guess it's written in Delphi (Object Pascal).

In any case, I've basically given up hope on X1 and am praying that a good replacement product comes along soon.
FRB
 
Posts: 3
Joined: Sun Feb 27, 2011 3:21 pm

Re: Anyone worked out how to recover vanishing X1?

Postby JBreault » Wed Mar 02, 2011 7:58 am

Just an fyi. X1 would pop up and then immediately shut down. By using the below solution, everything was fixed in a second. This is the second time I had to use this fix but it works seamlesssly.

Step 1:
1. Download this file: http://www.x1.com/cs/x1_index_repair_tool.exe
2. Double-click the downloaded EXE to run
3. You will be provided with a warning message, respond "Yes"
4. After running the tool, launch X1
JBreault
 
Posts: 26
Joined: Sat Jul 03, 2004 6:17 pm

Re: Anyone worked out how to recover vanishing X1?

Postby Kenward » Wed Mar 02, 2011 8:13 am

FRB wrote:Sooooo....They have a problem with corrupting their own indexes. If they are trying to maintain their own db, it obviously isn't working.

This may be the case, but another possibility is that something else is breaking the index.

I say that because X1 is not alone on having database problems. Outlook also breaks from time to time, with PST files that develop errors. As X1 reads those files, corruption in Outlook could cascade on to X1.

It may tell us something that Outlook has had its own database repair tool (scanspt.exe) for quite some time.

That Microsoft has not built checking and repair into Outlook may say something about the complexity of the task.
MK
X1 Search 8.5.2 - Build 6001si (64-bit)
Windows 10 Pro 64-bit | Windows 10 Home 32-bit
No, I have nothing to do with X1, just a user since 2004.
Kenward
X1 Guru
X1 Guru
 
Posts: 4107
Joined: Tue Apr 20, 2004 2:35 am
Location: UK

Re: Anyone worked out how to recover vanishing X1?

Postby pgk » Thu Mar 24, 2011 11:01 am

Is it known which versions suffer from this index corruption issue? Is this exclusively a 6.7.x problem? If so, hopefully the dev team can track down which code revision made X1 more susceptible to data corruption. BTW, thanks to Kenward for the best rant on the forum. As the kids say these days: +++++1.
pgk
X1 Super User
X1 Super User
 
Posts: 758
Joined: Thu Dec 18, 2003 8:13 am

Re: Anyone worked out how to recover vanishing X1?

Postby Chris Wheaton » Fri Mar 25, 2011 8:50 am

PGK – Our research shows that the cause of this “corruption issue” has been in the product for years, but likely manifested in a number of different ways making it challenging to confirm the true nature of the problem.

The X1 6.7 series of products have a substantial number of changes in the code that have cleaned up a number of “crashes” such that we are now seeing this problem in a concentrated manner. As a result we now believe we have identified the cause of the problem. Our engineering team is working on an improvement to X1 that should remedy this problem in our next release.
Sincerely,

Chris Wheaton
Technical Support
Customer Care Rep.
______________________

www.X1.com
Chris Wheaton
X1 Rep
X1 Rep
 
Posts: 299
Joined: Tue Dec 23, 2008 1:00 pm
Location: Pasadena, CA

Re: Anyone worked out how to recover vanishing X1?

Postby pgk » Fri Mar 25, 2011 1:55 pm

Sounds like good news, thanks for the heads up.
pgk
X1 Super User
X1 Super User
 
Posts: 758
Joined: Thu Dec 18, 2003 8:13 am

Re: Anyone worked out how to recover vanishing X1?

Postby Kenward » Fri Mar 25, 2011 3:18 pm

Indeed. Congratulations to the bug control.

Any hints on how we can avoid falling into this trap before you are ready to nuke the beast?
MK
X1 Search 8.5.2 - Build 6001si (64-bit)
Windows 10 Pro 64-bit | Windows 10 Home 32-bit
No, I have nothing to do with X1, just a user since 2004.
Kenward
X1 Guru
X1 Guru
 
Posts: 4107
Joined: Tue Apr 20, 2004 2:35 am
Location: UK

Re: Anyone worked out how to recover vanishing X1?

Postby wabe » Wed Apr 20, 2011 12:44 am

Had this problem a couple of days ago. Was unrecoverable, had to install and wipe settings plus reinstall from scratch.
wabe
 
Posts: 3
Joined: Wed Apr 20, 2011 12:37 am

Re: Anyone worked out how to recover vanishing X1?

Postby Chris Wheaton » Wed Apr 20, 2011 7:31 am

Wabe

We do regret of course that your X1 product "vanished" as is the main thought in this thread.

As discussed earlier in this thread the first thing to attempt is our repair tool:

1. Download this file: http://www.x1.com/cs/x1_index_repair_tool.exe
2. Double-click the downloaded EXE to run
3. You will be provided with a warning message, respond "Yes"
4. After running the tool, launch X1

If you did so and did not get relief from the problem then your form of "vanishing X1" is likely not the type that our tool was designed to correct.

The problem of course is that any time X1 vanishes, it simply vanishes. There could be 200 reasons for why it vanishes but they all look exactly alike.

Now that you have recovered from the incident you should visit this forum post to learn about the beta we released:
viewtopic.php?f=48&t=4941

The purpose of this release is better logging data so that we can dig deeper into these vanishing X1 issues with an eye toward correction within the product.
Sincerely,

Chris Wheaton
Technical Support
Customer Care Rep.
______________________

www.X1.com
Chris Wheaton
X1 Rep
X1 Rep
 
Posts: 299
Joined: Tue Dec 23, 2008 1:00 pm
Location: Pasadena, CA

Re: Anyone worked out how to recover vanishing X1?

Postby Kenward » Wed Apr 20, 2011 7:40 am

And if you do experience this issue with the new beta version, please also check the message that explains how to tell X1 about your incident.

Re: X1® Professional Client v6.7.3 Beta

This will provide X1 with more evidence that can help to eliminate this problem from future releases.
MK
X1 Search 8.5.2 - Build 6001si (64-bit)
Windows 10 Pro 64-bit | Windows 10 Home 32-bit
No, I have nothing to do with X1, just a user since 2004.
Kenward
X1 Guru
X1 Guru
 
Posts: 4107
Joined: Tue Apr 20, 2004 2:35 am
Location: UK

Re: Anyone worked out how to recover vanishing X1?

Postby plupa » Thu Apr 04, 2013 8:24 am

Well, I have a workaround.

The solution of doing a *complete* re-install does work, but the 2 days to rebuild the index was just not worth it. I did notice that I still had an X1 in my process bar and could select it.

So here's my work around.

Select X1 in process bar. ( It seems like it should be visible, but you can't find it on your desktop )
Use the windows keyboard short-cut for window operations: <ALT>space-bar to bring up the window menu
Select "maximize" on the window

X1 search is now in full window mode. If you change it to a resizeable window it will disappear, so just
leave it it full window mode.

Paul
plupa
 
Posts: 1
Joined: Thu Apr 04, 2013 7:58 am

Re: Anyone worked out how to recover vanishing X1?

Postby Chris Wheaton » Tue Apr 09, 2013 5:45 pm

Paul - thanks for helping the forum community on this topic. I would only add that once you have the interface back up again - set it to maximize or otherwise configure the UI the way you like it to appear normally, then use File > Exit to close X1 for about one minute or so.

Relaunch X1 thereafter and it should open "normally" as expected.
Sincerely,

Chris Wheaton
Technical Support
Customer Care Rep.
______________________

www.X1.com
Chris Wheaton
X1 Rep
X1 Rep
 
Posts: 299
Joined: Tue Dec 23, 2008 1:00 pm
Location: Pasadena, CA


Return to X1 Professional Client - 6.7.x (Raptor)

Who is online

Users browsing this forum: No registered users and 25 guests