X1 wont index .asp file types :(

This forum is to discuss general things about X1.

Moderator: Mods

X1 wont index .asp file types :(

Postby mgranic » Thu Dec 06, 2007 8:21 am

I'm a developer and I really like the indexing features of desktop search...I've been using it for several years. But one file type wont seem to get indexed. I have alot of .asp files on my system and even though I've added that extension to the file list (was not there for some reason), it still wont find these files when doing a search.

What's the problem?
mgranic
 
Posts: 5
Joined: Thu Dec 06, 2007 8:16 am

Postby w0qj » Thu Dec 06, 2007 10:43 am

At the risk of pointing out the obvious, did you try manually enable XEC indexing of *.ASP files' body contents?

Tools>>Options>>Files>>[More_Indexing_Options]


Then, do these two:

a) [Specify_File_Types], you add in *.ASP

b) Make sure XEC is indexing the folder(s) where your *.ASP files are located

Good luck!
Rgds / Mr. Wong

"It is what X1 can do with the information found that is important."
w0qj
X1 Guru
X1 Guru
 
Posts: 1183
Joined: Wed Jun 16, 2004 3:53 am
Location: Hong Kong

Postby mgranic » Thu Dec 06, 2007 10:52 am

w0qj wrote:At the risk of pointing out the obvious, did you try manually enable XEC indexing of *.ASP files' body contents?

Tools>>Options>>Files>>[More_Indexing_Options]


Then, do these two:

a) [Specify_File_Types], you add in *.ASP

b) Make sure XEC is indexing the folder(s) where your *.ASP files are located

Good luck!


Thanks for the response. There's never a risk of pointing out the obvious :)

But in this case, I have added the ".ASP" as an extension. If you add "*.asp", then it converts it to ".*.ASP" for you for some odd reason, so I just kept the ".ASP" extension. And I am indexing the entire drive and it picks up other file types, but for some reason not this one.

Here's a thought; can the file types that show in the default file types be updated or added to through some mechanism?

Any ideas are greatly appreciated :)
mgranic
 
Posts: 5
Joined: Thu Dec 06, 2007 8:16 am

Postby w0qj » Thu Dec 06, 2007 8:52 pm

Pls check if XEC had finished its Initial Indexing?
Initial Indexing the entire C:\ drive takes a long time, and there's a chance it might not have finished this yet...

To check this, try this:

1) Try typing in this under [Files]>>[Document_Type]
asp=

If your file isn't even in this list of all *.asp files found, then XEC definitely had not finished its Initial Indexing, pls give it more time...

2) Check unders [Files] and see how many files has XEC found on your C:\ hard drive... and compare this with how many files are actually there on your C:\ hard drive (goto WIndows Explorer, right-click C:\, and select [Properties] which will list how many files and folders).

If the results are very different (say XEC is reporting thousands of files less than C:\ count), then XEC definitely had not finished its Initial Indexing...


Good luck!
Rgds / Mr. Wong

"It is what X1 can do with the information found that is important."
w0qj
X1 Guru
X1 Guru
 
Posts: 1183
Joined: Wed Jun 16, 2004 3:53 am
Location: Hong Kong

Postby mgranic » Fri Dec 07, 2007 8:37 am

w0qj wrote:Pls check if XEC had finished its Initial Indexing?
Initial Indexing the entire C:\ drive takes a long time, and there's a chance it might not have finished this yet...

To check this, try this:

1) Try typing in this under [Files]>>[Document_Type]
asp=

If your file isn't even in this list of all *.asp files found, then XEC definitely had not finished its Initial Indexing, pls give it more time...

2) Check unders [Files] and see how many files has XEC found on your C:\ hard drive... and compare this with how many files are actually there on your C:\ hard drive (goto WIndows Explorer, right-click C:\, and select [Properties] which will list how many files and folders).

If the results are very different (say XEC is reporting thousands of files less than C:\ count), then XEC definitely had not finished its Initial Indexing...


Good luck!


Ok, the .asp files are definitely there, and if I go to the files tab and type .asp (same as the documents tab and asp=) all of them are listed. But for some odd reason, it wont index their contents :(

Isn't this the most basic, simple thing for this product to do? I was tried the Google Desktop, but it's interface is awful. I do alot of ASP work and I really need something that can parse it.

any other ideas?
mgranic
 
Posts: 5
Joined: Thu Dec 06, 2007 8:16 am

Postby mgranic » Fri Dec 07, 2007 8:58 am

addy999 wrote:well buddy use manually enable X-EC indexing of ASP files .... 8)


I'm not sure what you mean? When I get into the 'Specify File Types' dialog, I can add the additional extensions but it just doesnt work. I'm wondering if that feature is complete if you're using the free version.

Does anybody know where x1 gets the master list of the default files to be content-indexed?
mgranic
 
Posts: 5
Joined: Thu Dec 06, 2007 8:16 am

Postby pgk » Fri Dec 07, 2007 3:31 pm

If you added the asp files in the 'specify file types', then those files are set to be context indexed. Something you may try: in the dialog where you select the folders, there are different levels of indexing that you can pick. Tools > Options > Files > More indexing options. In the 'choose a folder' section (which by the way should be called 'select folders to index'..), clicking a folder cycles through different levels of indexing:

1. filenames only
2. filenames + content for specified files
3. contents for all files
4. none

I assume 'specified files' here means that it would include asp. So my recommendation: make sure that the folder that your files are in is 'indexed at' level 2 or 3. Either of these should then content index your asp files. -pgk
pgk
X1 Super User
X1 Super User
 
Posts: 757
Joined: Thu Dec 18, 2003 8:13 am

Postby mgranic » Fri Dec 07, 2007 7:12 pm

pgk wrote:If you added the asp files in the 'specify file types', then those files are set to be context indexed. Something you may try: in the dialog where you select the folders, there are different levels of indexing that you can pick. Tools > Options > Files > More indexing options. In the 'choose a folder' section (which by the way should be called 'select folders to index'..), clicking a folder cycles through different levels of indexing:

1. filenames only
2. filenames + content for specified files
3. contents for all files
4. none

I assume 'specified files' here means that it would include asp. So my recommendation: make sure that the folder that your files are in is 'indexed at' level 2 or 3. Either of these should then content index your asp files. -pgk


Thanks pgk, I'll check that out as well. I found a file in the Programs->X1 folder called whitefiles.xml (or something like that) and added the .asp file extension to the web group (which included HTML, etc). It then showed up as an extension in the default file list. I'm hoping that this resolves the issue.
mgranic
 
Posts: 5
Joined: Thu Dec 06, 2007 8:16 am


Return to General Discussion

Who is online

Users browsing this forum: No registered users and 29 guests

cron