Page 1 of 1

Quick Launch Keyboard Shortcut Disappeared

PostPosted: Tue Jun 17, 2008 6:02 am
by thinkstorm
Hello,

The options dialog at "Keyboard Shortcuts" does not show any drop-down box anymore for "Keyboard Shortcut for Launching X1 from the Desktop"

Is there a .ini entry I could add? I set it to CTRL-ALT-X, no other program is using that shorcut.

Cheers,
Thorsten

PostPosted: Tue Jun 17, 2008 7:05 am
by Kenward
Which version of X1 you use?

Have you tried a "Repair" or reinstalling X1 on top of itself?

Many of the settings are in the file barsettings.ini, others are in X1Config.ini.

The location of these depends on your operating system, so it is best just to search for them.

In Vista they are here:

C:\Users\{username}\AppData\Local\X1 Desktop Search\

PostPosted: Tue Jun 17, 2008 8:21 am
by thinkstorm
Yes, I tried to repair, no luck.

The hotkey section within the .ini script only shows the access keys to email. files, documents, etc. searches...

Any other idea?

Can anyone look into his/her .ini file for the shortcut code for CTRL-ALT-L?

PostPosted: Tue Jun 17, 2008 12:17 pm
by Tod
Is it possible that you deleted your X1 shortcut out of the Start menu and/or are not launching it on startup? I have heard that the shortcut key will not work in this case, but I have not had a chance to try it. Here are some things to look for:
1) HKLM/Software/X1 Desktop Search/ProgramMenuShortcutPath = C:\Documents and Settings\<username>\Start Menu\Programs\Startup\
2) HKLM/Software/X1 Desktop Search/ProgramMenuShortcutFilename = X1.lnk
3) X1.lnk must exist in the above path on disk and have a Ctrl+Alt shortcut key assigned in it when you view its properties.
4) you must also have the "Load X1 at startup" checked in the Basic page of Options dialog.

PostPosted: Sat Jun 21, 2008 7:06 pm
by thinkstorm
Yep, that's the case - I deleted the .LNK shortcut in the startup menu. I saw that it had the CTRL-ALT-X keyboard shortcut attached to it (I changed it from the CTRL-ALT-L), but it did not work. I only load the system tray icon by default.

X1 was loading *once* when it was invoked through the keyboard shortcut the first time, but that was it - any subsequent usage of the shortcut key didn't work anymore, and as I said, the options setting was gone.

I found a work around through AutoHotkey (http://www.autohotkey.com):
Code: Select all
^!x::
   DetectHiddenWindows, On
   SetTitleMatchMode, 1
   WinGet, hwnd, ID, X1 - ahk_class TApplication
   If hwnd
   {
      WinRestore, ahk_id %hwnd%
      ;SendMessage, 0x112, 0xf120,,,ahk_id %hwnd%
   } else {
      Run, C:\Program Files\X1\X1.exe
   }
Return


Cheers,
Thorsten