Control indexing subst disks

This forum is to discuss general things about X1.

Moderator: Mods

Control indexing subst disks

Postby tlmercur1 » Mon May 21, 2012 11:51 am

Hi,
I see problem where if I use the subst command like m:\s subst m: c:\ that X1 will on it own then index all of the m:\ drive which is exactly like the c:\ (it doubles all the entries.)

I understand there is option from menu to select which drives to index and which directories to index. I have these carefully selected for the c: drive to a few directories.

When I create the M: drive thru subst I later find that X1 has indexed all of M: and will now include it when I do searches. This is not what I want it to do.

1. how do I tell X1 not to automatically start indexing subst drives I create occasionally?

2. how do I eliminate all the m:\ drive entries now in my indexing db?
tlmercur1
 
Posts: 1
Joined: Mon May 21, 2012 11:40 am

Re: Control indexing subst disks

Postby noel » Wed May 23, 2012 10:57 am

Hello,

Unfortunately, there is no way to tell X1 to automatically ignore new drives that appear as a result of using the SUBST command. I'll put in a feature request with our developers to get this done.

As a possible workaround (if you are using Windows Vista/7), you can use symlinks using the MKLINK command. To make this work, you would need to create a folder and exclude that from being indexed in X1 (for example, C:\my_symlinks). Then, create symlinks under that folder. Hopefully, that works for you until we can sort out the behavior of new drive letters in X1.

To clear the index of the unwanted SUBST mapping, simply go to the X1 Options and clear the checkbox for indexing the SUBST drive. During the next index update, the items should clear.

-Noel
Noel Ferreria
noel
X1 Super User
X1 Super User
 
Posts: 478
Joined: Mon Nov 17, 2003 2:05 pm
Location: Pasadena, CA


Return to General Discussion

Who is online

Users browsing this forum: No registered users and 44 guests

cron