Page 1 of 1

Very slow forum site

PostPosted: Mon Oct 19, 2015 8:33 pm
by mrwul
It strikes me that the forum website is very slow. For instance: changing from one item to another, or from one group to another takes a long time.
All the time it says 'waiting for X1.com' in the status bar. When it takes too long, I give up. Sometimes I wait for 30-40 seconds.
Oh .. and eh.. NO, it is not an issue on my site: I have a fairly high-speed connection and other sites show up in a split second.

=

edit:
after I clicked on [Submit] button, it took 40 seconds before the above was finally posted.

Re: Very slow forum site

PostPosted: Fri Oct 30, 2015 11:34 am
by Michael Devin
Hello,

Upgrading the forum is in the 2016 year plans for X1. Like you, we are looking forward to having a new system that is faster with more functionality! Does anyone have recommendations for platforms? We use zendesk on a limited basis for our knowledge base, but are open to suggestions. It is a space that has changed a bunch over the last few years, so let us know if you have a platform that you think is fast and intuitive.

Best,

X1 Team

Re: Very slow forum site

PostPosted: Sat Oct 31, 2015 12:26 am
by mrwul
Are you talking about the phpBB software on which the forum is running?
If so, frankly, my personal idea would be to stick to it. I don't know anything about licensing costs, maintenance, whatsoever.
At the bottom it says "Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group "
Don't know the version number, but think phpBB is at 3.1.16
Nowadays companies very often use different forum software and ever so often such software is far from userfriendly,
it is lacking features, requires too many clicks to accomplish things, use wayyy too much white space, i.e. require a lot of
scrolling, no way to edit / delete the post after sending, no autosave, etc.etc.

phpBB has been around for many years and have built up a lot of experience, so, if I were to decide I would stick to it.
I think it has a lot of features that can be configured?
One of things I would like to see (if availabel)
1) Autosave
2) Edit (after sending)
3) Delete (after sending and as long as there no reply)
4) Insert inline image, see below. (attachement, upload, place in line)
5) And .. if possible... have an option to show the image as a thumbnail, instead of full screen: when users click on it, it will display it as full screen.

BTW right now forum is responding fairly fast, it was drama a while ago.
no clue what has been changed.

oh, ... I don't know whether or not a log-on session time has been set, but set it to 1 or 2 hours or so.
it is really frustrating having written a log post, doing some checking on other websites at the same time, but when sending the post
discover that one has been logged out and the post has gone. Often I create clipboard copy of the text, but not always...
=

==> ADDED:

one of the things that should improve: allow users to update their email address (user control panel).
have sent support a few reminders, but no response.
X1 forum is maybe one of the very few that does not allow users to change their email address..

=