X1 Search 8.5 Beta Release 4 Build 6001lz

Please post all issues related to the X1 Search 8.4 Beta Here!

Moderator: Mods

X1 Search 8.5 Beta Release 4 Build 6001lz

Postby Michael Devin » Tue Oct 04, 2016 8:53 pm

Hello forum community,

Based on your feedback the last few days, we are pleased to announce the next beta release of X1 Search 8.5 (Build 6001lz).

We list out the additional enhancements and fixes below. For a comprehensive list of all enhancements part of the 8.5 beta thus far, please see the bottom of this post. Please download soon and we look forward to your feedback.

You can download the beta MSI installer here:
32 bit: http://download.x1.com/downloads/search/beta_8_5/6001lz/X1Search32.msi
64 bit: http://download.x1.com/downloads/search/beta_8_5/6001lz/X1Search.msi


You can also use the bootstrapper to install (you may already have this from the previous betas):
http://download.x1.com/downloads/search/beta_8_5/X1SearchSetup_Beta_8_5.exe

Search 8.5 6001lz Beta Release Notes

*Fixed a bug that prevented proper shutdown of X1ServiceHost.exe
*Fixed a bug that prevented finding terms after bullet points
*Optimized text extraction of large documents to improve search accuracy
*Add support for indexing contents and preview of WinZip Zipx (.zipx) file format

Full X1 Search 8.5 beta release notes:

New Features/Enhancements

• Newly designed application flyout menu and application settings pages
• Send by Email post-search action now populates the subject with the names of the files
• GPO to ignore PST warnings when they’re not available (i.e. on offline network shares)
• GPO to automatically select MS Exchange online archive for indexing
• Improved Outlook scanner stability when entering sleep / hibernation
• Outlook 2013/2016 support for indexing offline content from folders that are partially cached
• Fixed the preview zoom to support high-definition 4k monitors
• Fixed all application icons to support high-definition 4k monitors
• Added configurable hotkeys for saved searches in the navigation panel
• Additional hotkeys for common UI tasks - E.g. Alt+D to focus the main search box
• IMAP Plugin: Fixed a problem with opening attachments and added “Download Attachment” Post-Search Action
• Allow main window width to become half-screen when the preview is on the bottom, or turned off
• Indicate max document size limit for indexing in the Files Options dialog
• Added option to disable “fast-as-you-type” search and replace with a traditional search button
• Stability fixes when indexing network PSTs. Ability to turn off warning dialog when they’re not available.
• Rapid: adjust timeout when searching against Rapid server
• Rapid: ensure proper sort order is executed against Rapid server
• Fixed a bug introduced in Beta 1 that prevented launch of X1 on non-English OS
• Fixed a bug that caused temp files to build up while scanning MSG files on the filesystem
• Fixed a bug that caused a tag interface to display when it should not
• Fixed a crash in the X1 index engine when updating index items
• Fixed a crash in the X1 index engine when indexing large XLS files

As a summary, at your request we have added a series of hotkeys listed below:

• Alt+D to focus to the main search box
• Ctrl+Alt+O - Options dialog
• Ctrl+Alt+D - Data Sources dialog
• Ctrl+Alt+A - About dialog
• Ctrl+Alt+H - Online help
• Ctrl+Alt+R - Set preview right
• Ctrl+Alt+B - Set preview bottom
• Ctrl+Alt+F - Set preview off


Also, the searches in the navigation tree/favorites bar will have configurable shortcuts, with the defaults being set as:

• Email: Ctrl+Shift+E
• Inbox: Ctrl+Shift+I
• Sent Items: Ctrl+Shift+S
• Attachments: Ctrl+Shift+T
• Files: Ctrl+Shift+F
• Documents: Ctrl+Shift+D
• Pictures: Ctrl+Shift+P
• Music: Ctrl+Shift+M
• Calendar: Ctrl+Shift+Q
• Tasks: Ctrl+Shift+K
• Contacts: Ctrl+Shift+C
• All: Ctrl+Shift+A

Thanks again for your continued support, and please keep the feedback coming.

Best,

Mike
Michael Devin
 
Posts: 48
Joined: Wed Nov 09, 2011 12:55 pm

Re: X1 Search 8.5 Beta Release 4 Build 6001lz

Postby gjbthx1 » Wed Oct 05, 2016 1:08 am

I have Windows 10 64 bit OS and Outlook 2010 32 bit installed on a machine. Should I be installing the 32 bit or 64 bit version of X1. Something tells me it should be the 32 bit version, the same as Outlook, even though the OS is 64 bit
gjbthx1
X1 Power User
X1 Power User
 
Posts: 56
Joined: Mon Nov 21, 2011 11:13 am

Re: X1 Search 8.5 Beta Release 4 Build 6001lz

Postby Kenward » Wed Oct 05, 2016 6:52 am

The 64-bit version of X1 now works happily with 32-bit Office.
MK
X1 Search 8.5.2 - Build 6001si (64-bit)
Windows 10 Pro 64-bit | Windows 10 Home 32-bit
No, I have nothing to do with X1, just a user since 2004.
Kenward
X1 Guru
X1 Guru
 
Posts: 4069
Joined: Tue Apr 20, 2004 2:35 am
Location: UK

Re: X1 Search 8.5 Beta Release 4 Build 6001lz

Postby gjbthx1 » Thu Oct 06, 2016 12:11 am

Thank you for confirming that Kenward.
gjbthx1
X1 Power User
X1 Power User
 
Posts: 56
Joined: Mon Nov 21, 2011 11:13 am

Re: X1 Search 8.5 Beta Release 4 Build 6001lz

Postby mrwul » Tue Oct 11, 2016 1:54 am

A few questions:
1) Question: Until when is this beta valid?
2) I had an error, trial expired, downloaded x1searchsetup.exe
and used that one. but got an error.

Image

(users are on their own to: -figure out which logs, -where to look for them and how the 'errors' may look like)
after trying a few times I gave up.

3) downloaded this beta (release 4 6001lz) and installed that one.
my A/V warned me

=
Image
=

3) Quations: if the beta's are over and a final version is released and I am getting above 'check your log file'-errors,
how am i to proceed ??

Meaning, I might uninstall the beta, so -hopefully- a clean install of the final might not me the errors
but then again, how to safeguard my settings? (which folder, which .pst, which documents, which, which ...)
probably I am supposed to set things up from scratch again?

=
mrwul
X1 Super User
X1 Super User
 
Posts: 305
Joined: Sun Jul 23, 2006 12:59 am

Re: X1 Search 8.5 Beta Release 4 Build 6001lz

Postby Kenward » Tue Oct 11, 2016 3:33 am

mrwul wrote:A few questions:
1) Question: Until when is this beta valid?



> Menu
> Info

expires 2017-01-31
MK
X1 Search 8.5.2 - Build 6001si (64-bit)
Windows 10 Pro 64-bit | Windows 10 Home 32-bit
No, I have nothing to do with X1, just a user since 2004.
Kenward
X1 Guru
X1 Guru
 
Posts: 4069
Joined: Tue Apr 20, 2004 2:35 am
Location: UK

Re: X1 Search 8.5 Beta Release 4 Build 6001lz

Postby swhx1 » Wed Oct 12, 2016 10:34 am

You reached out to us to Report a Problem and it was received Oct 12, 2016 10:30 AM Pacific Standard Time.

Here are the details of your submission:

Type of Case: Report a Problem

Support Status (optional): Expired X1 support contract customer

Which X1 Solution are you using?: X1 Client

Version of X1: Newer Product 8.5 beta 6001lz (64 bit)

Operating System: Windows 10 64-bit

Email Client (optional): Gmail

Description of the issue you are reporting:

8.5 beta 6001lz (64 bit) stops working "x1 search has stopped working" when i click on .mhtml files. its random. some open some dont. this just started happening after the MS updates on 10/11/16 namely KB3194798 and adobe flash player update (only 2). .mhtml files were always fine before. I also note the prior beta of x1 did the same thing today. See diagnostic files attached

Your information is being uploaded to our case management system and you should receive a follow-on confirmation along with additional information on your query.
Windows 10 Home 64 bit | Intel core i5-6400 cpu
swhx1
 
Posts: 36
Joined: Tue May 27, 2014 1:40 pm
Location: USA California

Re: X1 Search 8.5 Beta Release 4 Build 6001lz

Postby poy » Thu Oct 13, 2016 4:13 am

Installed 8.5β
After ~1.2 Mio Files this error was displayed:
"nicht genügend quoten verfügbar um diesen befehl zu verarbeiten."
Which means: "not enough quota available to process this command"
There were ~15GB Ram Free of 24GB.

Kind regards,
()
- < ( Connection with X1 Service has been lost. A restart does not fix this Problem. Would you like to restart X1?
()

Intel® Core™ i7-3740QM Processor 3.70 GHz - 24GB RAM - 1.5TB SSD - Win7 Ultimate 64bit
poy
X1 Power User
X1 Power User
 
Posts: 59
Joined: Wed Jun 27, 2012 11:33 am

Re: X1 Search 8.5 Beta Release 4 Build 6001lz

Postby swhx1 » Thu Oct 13, 2016 1:08 pm

Re-indexing my index now on this beta. So far customer service has not helped with .mhtml file issue. Their suggestion was to re-index and I already see that has not solved the issue
Windows 10 Home 64 bit | Intel core i5-6400 cpu
swhx1
 
Posts: 36
Joined: Tue May 27, 2014 1:40 pm
Location: USA California

Re: X1 Search 8.5 Beta Release 4 Build 6001lz

Postby swhx1 » Thu Oct 13, 2016 3:05 pm

swhx1 wrote:Re-indexing my index now on this beta. So far customer service has not helped with .mhtml file issue. Their suggestion was to re-index and I already see that has not solved the issue


Now I am about 40% done with the index and it keeps saying connection with the x1 service has been lost a restart may fix this problem. I do that and it just will not restart indexing. great solution
Windows 10 Home 64 bit | Intel core i5-6400 cpu
swhx1
 
Posts: 36
Joined: Tue May 27, 2014 1:40 pm
Location: USA California

Re: X1 Search 8.5 Beta Release 4 Build 6001lz

Postby Kenward » Fri Oct 14, 2016 10:15 am

swhx1 wrote:Re-indexing my index now on this beta. So far customer service has not helped with .mhtml file issue.


I can confirm, and have reported, that the current X1 beta crashes when I try to filter a search to display on mhtml files.
MK
X1 Search 8.5.2 - Build 6001si (64-bit)
Windows 10 Pro 64-bit | Windows 10 Home 32-bit
No, I have nothing to do with X1, just a user since 2004.
Kenward
X1 Guru
X1 Guru
 
Posts: 4069
Joined: Tue Apr 20, 2004 2:35 am
Location: UK

Re: X1 Search 8.5 Beta Release 4 Build 6001lz

Postby swhx1 » Fri Oct 14, 2016 11:17 am

Kenward wrote:
swhx1 wrote:Re-indexing my index now on this beta. So far customer service has not helped with .mhtml file issue.


I can confirm, and have reported, that the current X1 beta crashes when I try to filter a search to display on mhtml files.


Thanks for the confirmation Ken. Unfortunately I have over 6000 mhtml files! I am on win 10 like you but 64 bit and also 64 bit x1. odly I had so say with 32 bit firefox due to some google plug in issues. but the mhtml file are rather generic and can be created or read in firefox (via plug in) or chrome (via settings)

xi indexes them and opens some but not others. no reason that I can see. Now my 6000lz stopped indexing at 22.22% Jammed and looses contact with x1 server.

you never realize how much you need / rely on something until it does not work!
Windows 10 Home 64 bit | Intel core i5-6400 cpu
swhx1
 
Posts: 36
Joined: Tue May 27, 2014 1:40 pm
Location: USA California

Re: X1 Search 8.5 Beta Release 4 Build 6001lz

Postby hyoshida » Sat Oct 15, 2016 3:43 pm

I installed 8.5 beta r4 build 6001lz on Windows 10 64 bit + Outlook 32 bit. Both 64 and 32 versions of X1 Search says "Connection with the X1 Service has been lost" at first launch (!) Is this a known issue?
hyoshida
 
Posts: 3
Joined: Sat Oct 15, 2016 3:39 pm

Re: X1 Search 8.5 Beta Release 4 Build 6001lz

Postby Kenward » Sun Oct 16, 2016 3:42 am

hyoshida wrote:Is this a known issue?


Not for this beta in particular, but it is a constant refrain.

Some people see it from time to time, some don't. Sometimes it happens once then normality returns. Sometimes it persists.

X1 has never come up with a convince explanation or a long term fix.
MK
X1 Search 8.5.2 - Build 6001si (64-bit)
Windows 10 Pro 64-bit | Windows 10 Home 32-bit
No, I have nothing to do with X1, just a user since 2004.
Kenward
X1 Guru
X1 Guru
 
Posts: 4069
Joined: Tue Apr 20, 2004 2:35 am
Location: UK

Re: X1 Search 8.5 Beta Release 4 Build 6001lz

Postby Kenward » Sun Oct 16, 2016 4:02 am

A problem persists from earlier versions.

  • Ctrl Ctrl Ctrl
  • Up comes X1
  • Start typing search
  • Nothing happens (X1 does not take focus)
Even when it does start taking text, it sometimes loses focus after typing a character or two.
MK
X1 Search 8.5.2 - Build 6001si (64-bit)
Windows 10 Pro 64-bit | Windows 10 Home 32-bit
No, I have nothing to do with X1, just a user since 2004.
Kenward
X1 Guru
X1 Guru
 
Posts: 4069
Joined: Tue Apr 20, 2004 2:35 am
Location: UK

Re: X1 Search 8.5 Beta Release 4 Build 6001lz

Postby hyoshida » Sun Oct 16, 2016 11:38 am

Kenward wrote:
hyoshida wrote:Is this a known issue?


Not for this beta in particular, but it is a constant refrain.

Some people see it from time to time, some don't. Sometimes it happens once then normality returns. Sometimes it persists.

X1 has never come up with a convince explanation or a long term fix.


When I removed files with long (>260 chrs) path names, it resumed the connection, at least for now. It appears that the X1ContentExtraction.exe crashed on indexing long name files. Is/Was this a known issue in the previous (and current) versions?

-- Hiro
hyoshida
 
Posts: 3
Joined: Sat Oct 15, 2016 3:39 pm

Re: X1 Search 8.5 Beta Release 4 Build 6001lz

Postby swhx1 » Sun Oct 16, 2016 11:49 am

Hopefully in 14 days when I am back from my trip this will be ironed out. Customer service has not gotten back to me on mht files or x1 loosing connection with the server. (as far as some solution or work around) also after 22.22% of the indexing it just stopped. jammed. not sure why this beta introduced so many problems. has been running fine for months on prior beta. trying to help with the beta but not getting much help from x1. so much for beta testing

I assume I will need to uninstall everything (including reg. entries) and start from scratch with the next beta but no time for that stuff now before my trip
Last edited by swhx1 on Mon Oct 17, 2016 9:12 am, edited 1 time in total.
Windows 10 Home 64 bit | Intel core i5-6400 cpu
swhx1
 
Posts: 36
Joined: Tue May 27, 2014 1:40 pm
Location: USA California

Re: X1 Search 8.5 Beta Release 4 Build 6001lz

Postby RGlanzmann » Mon Oct 17, 2016 9:03 am

This release keeps crashing constantly. The only way to recover X1 is to kill all processes manually. Error message:

"not enough quota available to process this command".

Last time I checked out of 16GB RAM 7GB were free.

1.5 Million documents indexed.
RGlanzmann
 
Posts: 8
Joined: Fri Sep 23, 2016 12:29 pm

Re: X1 Search 8.5 Beta Release 4 Build 6001lz

Postby RGlanzmann » Tue Oct 18, 2016 11:08 am

Something is seriously wrong with the memory management of this release.

I tried to update my index of 1.5M documents. X1 takes up more and more memory, until it stops processing at 14GB out of 16GB RAM. Error message:

"not enough quota available to process this command". Every time.
RGlanzmann
 
Posts: 8
Joined: Fri Sep 23, 2016 12:29 pm

Re: X1 Search 8.5 Beta Release 4 Build 6001lz

Postby Scott » Tue Oct 18, 2016 7:06 pm

RGlanzmann wrote:Something is seriously wrong with the memory management of this release.

I tried to update my index of 1.5M documents. X1 takes up more and more memory, until it stops processing at 14GB out of 16GB RAM. Error message:

"not enough quota available to process this command". Every time.


Hi RGlanzmann, our QA and development teams have been discussing this and have asked if you could check your virtual page file settings (https://www.microsoft.com/resources/doc ... x?mfr=true) and let us know how they are configured. We've also found a couple of articles which provide more detail around the possible causes of the quota errors:

http://blog.coultard.com/2012/01/fix-wi ... nough.html

and

http://stackoverflow.com/questions/2096 ... ommand-wpf

Also, of it's not too much trouble could you possibly open a support ticket via the portal and provide diagnostic files? Here is the link to the support portal:

www.x1.com/support/x1_search.html#login

We appreciate you bringing this to our attention.
Scott
 
Posts: 5
Joined: Wed Sep 27, 2006 2:15 pm
Location: Pasadena

Re: X1 Search 8.5 Beta Release 4 Build 6001lz

Postby Scott » Wed Oct 19, 2016 2:54 pm

Hi RGlanzmann, our developers would also like to know which X1 process or processes are utilizing the 14-16GB of memory, if it's not too much trouble could you provide us with a screenshot of the task manager when this is happening that shows those processes? And we'd like to take a look at those diagnostic files as well. Much appreciated and we look forward to getting to the bottom of this for you.
Scott
 
Posts: 5
Joined: Wed Sep 27, 2006 2:15 pm
Location: Pasadena

Re: X1 Search 8.5 Beta Release 4 Build 6001lz

Postby hydrokiwi » Fri Oct 21, 2016 10:26 am

X1 is getting about 7% through indexing files and then stops.

It keeps asking to be rebooted as it has lost connection with the index service.

After many attempts, including removing file folders from the data source, I tried uninstalling the Beta and going back to 8.4 - but it cant find the index service.

What gives,.

Is there a log of indexing problems - so I can see what the problem is?

Cheers
John
hydrokiwi
 
Posts: 21
Joined: Tue Feb 09, 2010 10:34 am

Re: X1 Search 8.5 Beta Release 4 Build 6001lz

Postby hydrokiwi » Fri Oct 21, 2016 12:30 pm

Follow up question.

Why does indexing sometimes show as "cancelled" when I have not terminated it?

Cheers
John
hydrokiwi
 
Posts: 21
Joined: Tue Feb 09, 2010 10:34 am

stops indexing

Postby dacosolutions » Sat Oct 22, 2016 10:33 am

installed 64 bit version on win 10 64 with outlook 365 32 bit

I have 2.4M indexed items. Stops indexing files at 20% on drivers folder.

Also when I reboot it looses all indexed files in both onedrive locations so it has to reindex them each time I restart.
dacosolutions
 
Posts: 4
Joined: Mon Oct 17, 2016 2:32 pm

Send feedback link

Postby dacosolutions » Sat Oct 22, 2016 10:35 am

it open chrome to a blank "google.com" search ...

should't it open an e-mail to send feedback?
dacosolutions
 
Posts: 4
Joined: Mon Oct 17, 2016 2:32 pm

What to do when 8.5 Indexing self cancels - go back to 8.4?

Postby hydrokiwi » Mon Oct 24, 2016 8:51 am

So Outlook email seems to be getting indexed OK but the files indexing is stopping at about 90% complete.

It just stops and says "Cancelled".

I cant tell which file or folder or what is stopping the process.

I have tried uninstalling and reinstalling 8.5 - no change.

Is a complete Uninstall of 8.5 Beta and reinstall of 8.4 releases a solution or is that not going to solve the problem. Or is there any other solution?

Indexing takes a day or so I dont want to have to start over again - if I dont need to.

Cheers
John
hydrokiwi
 
Posts: 21
Joined: Tue Feb 09, 2010 10:34 am

Re: X1 Search 8.5 Beta Release 4 Build 6001lz

Postby masta blasta » Tue Oct 25, 2016 5:32 am

@hydrokiwi exact same behaviour on my end. in my case the indexing seems to have an issue with msg files and cancels the indexing process when it encounters them.
masta blasta
 
Posts: 6
Joined: Tue Oct 25, 2016 5:28 am

Re: X1 Search 8.5 Beta Release 4 Build 6001lz

Postby hydrokiwi » Tue Oct 25, 2016 11:39 am

Masta Blasta - thanks for the feedback.

I am not getting anything back from X1 on this. Maybe this beta is an experiment that just did not work. Having a log of the indexing process which identifies the exception might be helpful.

I am in the process of reinstalling 8.4 and reindexing - I do rely heavily on desktop search in my daily work.

Cheers
John
hydrokiwi
 
Posts: 21
Joined: Tue Feb 09, 2010 10:34 am

Re: X1 Search 8.5 Beta Release 4 Build 6001lz

Postby masta blasta » Wed Oct 26, 2016 2:06 am

no problem hydrokiwi, you can also access the logs by browsing to this folder C:\Users\"user you are logged in as"\AppData\Local\X1 Search\logs the log that is relevant to this error is X1ServiceHost.log before you uninstall version 8.5 could you check whether this entry appears in the log ?

[Files] ERROR FilesConnector - Scan interrupted by exception in connector
System.ArgumentOutOfRangeException: Not a valid Win32 FileTime.
Parameter name: fileTime
at System.DateTime.FromFileTimeUtc(Int64 fileTime)
at System.IO.FileSystemInfo.get_LastWriteTime()
at cl.a(FileInfo A_0)
at cl.d.d()
at Scanner.BaseConnector.ScanFolder(ConnectorItem folder, ProgressReporter progressReporter)
at Scanner.BaseConnector.ScanFolder(ConnectorItem folder, ProgressReporter progressReporter)
at Scanner.BaseConnector.ScanFolder(ConnectorItem folder, ProgressReporter progressReporter)
at Scanner.BaseConnector.GetAllItems()

i'd appreciate it if someone else confirmed that this entry appears when the indexing process is cancelled.
masta blasta
 
Posts: 6
Joined: Tue Oct 25, 2016 5:28 am

Re: X1 Search 8.5 Beta Release 4 Build 6001lz

Postby hydrokiwi » Wed Oct 26, 2016 8:49 am

Masta blaster - thanks for the input regarding the logs.

Unfortunately I have uninstalled 8.5 and reinstalled 8.4 and reindexed.

8.4 completes the indexing OK without the same "Cancelled" problem so something has changed in the indexing algorithm which is causing early termination of file search.

It is good to have it working again.

Cheers
John
hydrokiwi
 
Posts: 21
Joined: Tue Feb 09, 2010 10:34 am

Re: X1 Search 8.5 Beta Release 4 Build 6001lz

Postby masta blasta » Thu Oct 27, 2016 4:23 am

seems i'll have to do the same. whatever it is the cancelled problem started with the last two betas.
masta blasta
 
Posts: 6
Joined: Tue Oct 25, 2016 5:28 am

Re: X1 Search 8.5 Beta Release 4 Build 6001lz

Postby swhx1 » Mon Oct 31, 2016 11:49 am

I think its time for a new beta. no news from customer service on my issues which I first sent to them on oct 12. Now that I am back from vacation I had hoped a new beta (post 6001lz) would clean this mess up. Not indexing all my files on initial (freezes at 22.22%) index and crashing on trying to open most mhtml files. Again these are both NEW issues only on this beta
Windows 10 Home 64 bit | Intel core i5-6400 cpu
swhx1
 
Posts: 36
Joined: Tue May 27, 2014 1:40 pm
Location: USA California

Re: X1 Search 8.5 Beta Release 4 Build 6001lz

Postby swhx1 » Tue Nov 01, 2016 9:56 am

I hope the x1 people are reading this forum. They dont seem to be reacting. Sort of like google. Never tell users what is going on. Keep them in the dark waiting.
Windows 10 Home 64 bit | Intel core i5-6400 cpu
swhx1
 
Posts: 36
Joined: Tue May 27, 2014 1:40 pm
Location: USA California

Re: X1 Search 8.5 Beta Release 4 Build 6001lz

Postby dacosolutions » Tue Nov 01, 2016 11:34 am

I gave up and uninstalled 6001lz as it had so many problems and no one at X1 seems to be alive or care to respond to questions in weeks ... if you ask people to spend their time beta testing then the company should have the courtesy to take the feedback and provide a response or status or SOMETHING.

I went back to the stable version .. waste of time trying to help with testing beta products here.
dacosolutions
 
Posts: 4
Joined: Mon Oct 17, 2016 2:32 pm

Re: X1 Search 8.5 Beta Release 4 Build 6001lz

Postby swhx1 » Tue Nov 01, 2016 12:48 pm

what is the "stable" version? what link do I download it at? Also do they have compete manual unistall directions? I likely have to clean the registry or use some 3rd party uninstaller? any thoughts? I do think releasing a bad beta then not responding to any of the comments about the beta is cardinal sin in software development. If you ask my opinion I dont think things are well over at x1. if your marquee product is failing I think you should care.
Windows 10 Home 64 bit | Intel core i5-6400 cpu
swhx1
 
Posts: 36
Joined: Tue May 27, 2014 1:40 pm
Location: USA California

Re: X1 Search 8.5 Beta Release 4 Build 6001lz

Postby Kenward » Thu Nov 03, 2016 12:05 pm

You can get the last official release by logging into the support area:

Product Support for Desktop Search

That should show the latest that you are entitled to.

It is surprising that the folks at X1 have gone to sleep. (You should see the mountain of pending spam that the people who run this forum have not cleared out.) But I am not sure that X1 is the "marquee product", whatever that is. I suspect that the corporate market is bigger and more important. Maybe they are busily checking through Hillary's emails.
MK
X1 Search 8.5.2 - Build 6001si (64-bit)
Windows 10 Pro 64-bit | Windows 10 Home 32-bit
No, I have nothing to do with X1, just a user since 2004.
Kenward
X1 Guru
X1 Guru
 
Posts: 4069
Joined: Tue Apr 20, 2004 2:35 am
Location: UK

Re: X1 Search 8.5 Beta Release 4 Build 6001lz

Postby swhx1 » Sat Nov 05, 2016 8:20 pm

Well hearing nothing from customer service for two weeks I went off what they last suggested and that was delete my index as it was likely corrupted. So I uninstalled Search 8.5 (Build 6001lz) and my activation, the index and all registry entries. I then reinstalled Search 8.5 (Build 6001lz) and picked my file paths and file types and let it do an initial index. So far everything seems good. None of the bad behaviors from before. So for those of you that are willing to start from scratch I suggest you try it. I dont like reindexing as it takes hours but it seems to solve lots of issues. So I solved my own problems. When in doubt start from scratch
Windows 10 Home 64 bit | Intel core i5-6400 cpu
swhx1
 
Posts: 36
Joined: Tue May 27, 2014 1:40 pm
Location: USA California

Re: X1 Search 8.5 Beta Release 4 Build 6001lz

Postby kblount » Sun Nov 06, 2016 3:05 pm

I am curious if the beta versions of X1 include the ability to drag attachments from emails within X1 into new emails? I still do not understand why this functionality was dropped from 6.x to the 8.x version, but it is the only reason I've decided to stay at 6.7.4 on my primary work desktop. I have 8.x on my laptop, and keep hoping that this functionality one day returns.
kblount
 
Posts: 29
Joined: Tue Jan 16, 2007 10:50 am

Re: X1 Search 8.5 Beta Release 4 Build 6001lz

Postby Kenward » Mon Nov 07, 2016 3:11 am

kblount wrote:I am curious if the beta versions of X1 include the ability to drag attachments from emails within X1 into new emails?


No. Doesn't work.
MK
X1 Search 8.5.2 - Build 6001si (64-bit)
Windows 10 Pro 64-bit | Windows 10 Home 32-bit
No, I have nothing to do with X1, just a user since 2004.
Kenward
X1 Guru
X1 Guru
 
Posts: 4069
Joined: Tue Apr 20, 2004 2:35 am
Location: UK

Re: X1 Search 8.5 Beta Release 4 Build 6001lz

Postby poy » Mon Nov 07, 2016 4:26 am

swhx1 wrote:When in doubt start from scratch

Thank you for the suggestion.

However, I've done that so many times that it brings me to the conlusion that the index concept is flawed.

Years ago one of the advantages of X1 used to be that it would find things.

After several new installs, betas, re-indexes, unanswered forum questions, X1 never runs reliably.
It does not even index my machine's content completely.

Sooner or later X1 indexing hangs at certain points and never makes any progress,
no matter whether its a beta or the latest released version.
()
- < ( Connection with X1 Service has been lost. A restart does not fix this Problem. Would you like to restart X1?
()

Intel® Core™ i7-3740QM Processor 3.70 GHz - 24GB RAM - 1.5TB SSD - Win7 Ultimate 64bit
poy
X1 Power User
X1 Power User
 
Posts: 59
Joined: Wed Jun 27, 2012 11:33 am

Re: X1 Search 8.5 Beta Release 4 Build 6001lz

Postby swhx1 » Mon Nov 07, 2016 8:55 am

for those asking about dragging and dropping documents into emails. This feature has been around for a while in x1 for me and still works. I use it daily which is why I missed x1 so much. x1 has become my go to program for finding stuff daily. I select one or more items in x1 search result list and drag them into a draft email in gmail and release. Items load fine. I use gmail with firefox latest edition. I do not have outlook on my system
Windows 10 Home 64 bit | Intel core i5-6400 cpu
swhx1
 
Posts: 36
Joined: Tue May 27, 2014 1:40 pm
Location: USA California

Re: X1 Search 8.5 Beta Release 4 Build 6001lz

Postby Kenward » Tue Nov 08, 2016 3:11 pm

swhx1 wrote:for those asking about dragging and dropping documents into emails.


That's not what the recent discussion has been about. As kblount puts it, it is about

the ability to drag attachments from emails within X1 into new emails

Yes, you can drag documents, but can you drag attachments out iof emails?

I can't here.

Not having Outlook, you won't be able to test this one yourself.
MK
X1 Search 8.5.2 - Build 6001si (64-bit)
Windows 10 Pro 64-bit | Windows 10 Home 32-bit
No, I have nothing to do with X1, just a user since 2004.
Kenward
X1 Guru
X1 Guru
 
Posts: 4069
Joined: Tue Apr 20, 2004 2:35 am
Location: UK

Re: X1 Search 8.5 Beta Release 4 Build 6001lz

Postby RGlanzmann » Sun Nov 13, 2016 1:27 pm

Scott wrote:
RGlanzmann wrote:Something is seriously wrong with the memory management of this release.

I tried to update my index of 1.5M documents. X1 takes up more and more memory, until it stops processing at 14GB out of 16GB RAM. Error message:

"not enough quota available to process this command". Every time.


Hi RGlanzmann, our QA and development teams have been discussing this and have asked if you could check your virtual page file settings (https://www.microsoft.com/resources/doc ... x?mfr=true) and let us know how they are configured. We've also found a couple of articles which provide more detail around the possible causes of the quota errors:

http://blog.coultard.com/2012/01/fix-wi ... nough.html

and

http://stackoverflow.com/questions/2096 ... ommand-wpf

Also, of it's not too much trouble could you possibly open a support ticket via the portal and provide diagnostic files? Here is the link to the support portal:

http://www.x1.com/support/x1_search.html#login

We appreciate you bringing this to our attention.


Problem solved. I reset all virtual memory management settings according to the instructions and deleted the existing index. Guys, thank you for your help. I really appreciate it.
RGlanzmann
 
Posts: 8
Joined: Fri Sep 23, 2016 12:29 pm

Re: X1 Search 8.5 Beta Release 4 Build 6001lz

Postby RGlanzmann » Fri Nov 25, 2016 11:38 am

Every single time the file indexing is running the X1 Client stops responding to input. But on stopping the process X1ServiceHost.exe the Client immediately reports that the ServiceHost is no longer available ("Connection with the X1 service has been lost. A restart might fix the problem. Would you like to restart X1?"), so the Client is not really crashing but "stuck", because the ServiceHost is in a strange state. :(

I have currently 1.1M items indexed, mostly files on network shares. The last time a complete indexing was successful was a month ago - it takes ages and during the time the indexing is running the Client can no longer be used, as described.

Also: the indexing gets paused regularly for no apparent reason.

Anybody else having this problem?

What can I do to help you analyse this problem?
RGlanzmann
 
Posts: 8
Joined: Fri Sep 23, 2016 12:29 pm

Re: X1 Search 8.5 Beta Release 4 Build 6001lz

Postby Kenward » Fri Nov 25, 2016 2:07 pm

RGlanzmann wrote:What can I do to help you analyse this problem?


No.

For comparison, I have about a million files indexed and >670,000 email items. In all, Everything reports 1,839,671 items.

But nothing is on a network, share. Maybe that is the issue.

I have never thought of X1 is an "enterprise" product that can handle network stuff, even though it has some network abilities. In general, networking seems to be the devil's plaything when it comes to getting software to play nice over it. For example, getting PaperPort to work over a network can be a pain.

X1 does throw a wobbly from time to time. And can be slow in coming tio life. (I am on the 6001le version.) But is usually recovers.
MK
X1 Search 8.5.2 - Build 6001si (64-bit)
Windows 10 Pro 64-bit | Windows 10 Home 32-bit
No, I have nothing to do with X1, just a user since 2004.
Kenward
X1 Guru
X1 Guru
 
Posts: 4069
Joined: Tue Apr 20, 2004 2:35 am
Location: UK

Re: X1 Search 8.5 Beta Release 4 Build 6001lz

Postby swhx1 » Fri Nov 25, 2016 2:10 pm

I solved problem like this with doing a complete uninstall, registry wipe, index wipe and fresh install with new index. had to do it the hard way. Never did figure out all the problems the beta was having. dont have time to mess with this stuff
Windows 10 Home 64 bit | Intel core i5-6400 cpu
swhx1
 
Posts: 36
Joined: Tue May 27, 2014 1:40 pm
Location: USA California

Re: X1 Search 8.5 Beta Release 4 Build 6001lz

Postby hrr » Fri Nov 25, 2016 2:42 pm

I have a different problem with the Beta. Maybe someone can help. I am using 64 bit version of X1 Search, with 64 bit Win 10 Pro. We recently migrated Exchange accounts from CenturyLink to Office 365. All is well EXCEPT, despite the fact that X1 goes thru the motions and tells me my contacts are indexed and up to date, when I go to the main X1 Search screen, and click on Contacts, I get a "No Results" message. Can anyone help?
hrr
 
Posts: 31
Joined: Mon Aug 28, 2006 10:09 am

Re: X1 Search 8.5 Beta Release 4 Build 6001lz

Postby mrwul » Fri Nov 25, 2016 10:44 pm

Each time X1 stops indexing files at a certain point. After trying half a dozen times I checked and found that X1 stops indexing a specific folder.
The folder contains .msg files (separate Outlook messages, exported from Outlook)

Within that folder, with -roughly- 40-50 separate .msg files.

There are maybe 10-15 .msg files with :
1. filenames that start with 2 Chinese symbols - followed by 'normal' text
2. and where 'sent to', 'received from', 'message title' are Chinese characters, followed by normal text (see below)

Are there any solutions for this?
Like X1 only indexing normal European text and -skip- non-European characters.

I know there is an option (Options->Indexing) "Insert word breaks around Asian language characters" but do not know whether that will solve the issue.

Thanks.

=
Image

=====================

LATER
the only solution that worked is to skip the entire folder from indexing.
the folder contained 2 different filetypes, but X1 stumbled over the single .msg files and simply does not continue.
after many hours of repeated trying: in the settings, untag .msg (filetypes) and also untag the folder from being indexed.
probably I am the only one with this issue but nonetheless the above worked for me.
=
Last edited by mrwul on Fri Dec 02, 2016 11:50 pm, edited 1 time in total.
mrwul
X1 Super User
X1 Super User
 
Posts: 305
Joined: Sun Jul 23, 2006 12:59 am

Re: X1 Search 8.5 Beta Release 4 Build 6001lz

Postby Kenward » Sat Nov 26, 2016 2:49 am

hrr wrote:We recently migrated Exchange accounts from CenturyLink to Office 365.


Has Microsoft moved you over to the new servers yet?

Have you checked the configuration in X1?
MK
X1 Search 8.5.2 - Build 6001si (64-bit)
Windows 10 Pro 64-bit | Windows 10 Home 32-bit
No, I have nothing to do with X1, just a user since 2004.
Kenward
X1 Guru
X1 Guru
 
Posts: 4069
Joined: Tue Apr 20, 2004 2:35 am
Location: UK

Re: X1 Search 8.5 Beta Release 4 Build 6001lz

Postby hrr » Sat Nov 26, 2016 9:50 am

Yes to the move. That is certain. Everything works but Contacts. As to the configuration, I have checked everything I know how to check. Outlook Exchange email works as expected in X1. Calendar works as expected in X1. Only Contacts don't work. Is there some separate configuration step for Contacts that I should check?
hrr
 
Posts: 31
Joined: Mon Aug 28, 2006 10:09 am

Next

Return to X1® Search 8.5 Release

Who is online

Users browsing this forum: No registered users and 8 guests

cron