Page 1 of 1

Navigation Tree Hide/Show does not work

PostPosted: Tue Apr 25, 2017 6:37 am
by Trajan
I cannot get the Hide/Show Navigation Tree to work on a new install of X1. 8.5 6001qm (64-bit)

Is there a fix for this? It seems like a simple operation, just a click on the arrow, but it does not work.

Thanks!

Re: Navigation Tree Hide/Show does not work

PostPosted: Thu Apr 27, 2017 2:07 pm
by Kenward
I wish you hadn't said that.

It came up here recently. I was convinced I knew how to fix it – it worked the last time I answered the questiuoinb – but this time it is broken.

Back then I suggested that we need a hot key for this.

Maybe the beta that, some months ago, X1 promised in "a few weeks" will address this issue.

Re: Navigation Tree Hide/Show does not work

PostPosted: Thu Apr 27, 2017 2:11 pm
by Kenward
Try this.

  • Close X1 from the notification area.
  • Restart X1.
  • Click the arrow.

Worked here.

Clearly a bug.

Re: Navigation Tree Hide/Show does not work

PostPosted: Fri Apr 28, 2017 7:30 am
by Kenward
Kenward wrote:Clearly a bug.


And a reliably repeatable bug.

Although it does not repeat after you have restarted X1. It is a "first launch" feature.

Re: Navigation Tree Hide/Show does not work

PostPosted: Wed May 03, 2017 6:18 am
by Jogy
Hi

The bug will be fixed in the new 8.5.1 version that will be released very soon. Also added a shortcut - by default Ctrl+Alt+V, but can be configured by the user.

In the meantime, you can double-click on the line separating the navigation pane and the results view to hide the navigation pane, or if the navigation pane is hidden, you should be able to double-click on the left border of X1 window to restore it. If your mouse cursor is in the right place, it should change to a horizontal resize arrows.

Jogy

Re: Navigation Tree Hide/Show does not work

PostPosted: Thu May 04, 2017 8:12 am
by Kenward
Jogy wrote:or if the navigation pane is hidden, you should be able to double-click on the left border of X1 window to restore it.


This doesn't work. Not even after the close/reopen trick.

The cursor turns into the expected resize arrows but they do nothing UNLESS you are in full-screen, maximised, mode. "Cascaded" does nothing.

At least I know know that I can maximise the window to achieve the required effect.

Quirky to say the least.

Re: Navigation Tree Hide/Show does not work

PostPosted: Tue May 16, 2017 5:35 pm
by cscott
Kenward wrote:
Jogy wrote:or if the navigation pane is hidden, you should be able to double-click on the left border of X1 window to restore it.


This doesn't work. Not even after the close/reopen trick.

The cursor turns into the expected resize arrows but they do nothing UNLESS you are in full-screen, maximised, mode. "Cascaded" does nothing.

At least I know know that I can maximise the window to achieve the required effect.

Quirky to say the least.

This issue should be fixed in 8.5.1, which has been released today (5/16).

Re: Navigation Tree Hide/Show does not work

PostPosted: Wed May 17, 2017 2:22 am
by Kenward
cscott wrote:This issue should be fixed in 8.5.1, which has been released today (5/16).

A quick check suggests that this is indeed fixed. At least, the arrow on the "Favorites" bar works.

However, I cannot get it to work with a double-click on the left border.

You can also turn the navigation tree on and off from the View link in the status bar.

Sadly, not all of the keystrokes listed there work. (Ctrl+Alt+V) This may be because they are already tied to something else.

Is there any way to change these?

Re: Navigation Tree Hide/Show does not work

PostPosted: Wed May 17, 2017 2:36 am
by Jogy
Kenward wrote:
cscott wrote:This issue should be fixed in 8.5.1, which has been released today (5/16).

A quick check suggests that this is indeed fixed. At least, the arrow on the "Favorites" bar works.

However, I cannot get it to work with a double-click on the left border.

You can also turn the navigation tree on and off from the View link in the status bar.

Sadly, not all of the keystrokes listed there work. (Ctrl+Alt+V) This may be because they are already tied to something else.

Is there any way to change these?


Hi,

Unfortunately, when the window is not maximized, the left border is used for resizing the whole window and takes precedence over the functionality for resizing the navigation tree. For the moment we do not have a fix for that.

The Ctrl+Alt+V may not work because you have an old shortcut config file. Go to the Options page, then select the Shortcuts tab, and there should be a button to reset the shortcuts to default - reset, apply the changes, and then try again the shortcut.

Jogy

Re: Navigation Tree Hide/Show does not work

PostPosted: Wed May 17, 2017 6:23 am
by Kenward
Jogy wrote:Go to the Options page, then select the Shortcuts tab, and there should be a button to reset the shortcuts to default - reset, apply the changes, and then try again the shortcut.



Ah. That's where it is.

Sadly, it does not work, nor does assigning another shortcut.

Never mind. It isn't that important.