Files have stopped indexing

Please post all issues related to X1 Search 8 Releases here!

Moderator: Mods

Files have stopped indexing

Postby Kenward » Sat Apr 26, 2014 3:10 am

It seems that X1 8.2 has decided to stop indexing my files. It happily churns away at email, but for files it shows:

Last indexed: 12 April 12:49

This is a mere 14 days ago.

I have paused all other indexing. I have a search that should show all of the files I added this week. There are dozens of them. It finds just two.

Looking at the results for PDF files, it seems that X1 is simply taking for ever to work its way down the list of folders.

In trying to diagnose this, I find that X1 "forgets" my schedules for indexing. It reverts back to "every 10 minutes" for things that I had set to index at midnight. Maybe that is throwing it into tizzy.

X1 is now supposed to be indexing files. I have a carefully tailored search that should show me new PDF files add this week. There is little sign that it is achieving anything. The file count is not going up.

Oh, one final thing, every time I start my PC, X1 complains that it cannot connect. Indeed, this happens on every one of my three PCs. I have to start the process manually every day. That's a couple of hours lost indexing time.

What's with this long reported bug? Has anybody managed to get X1 to start properly when they reboot?
MK
X1 Search 8.6.1 - Build 6003fa (64-bit)
Windows 10 Pro 64-bit | Windows 10 Home 32-bit
No, I have nothing to do with X1, just a user since 2004.
Kenward
X1 Guru
X1 Guru
 
Posts: 4148
Joined: Tue Apr 20, 2004 2:35 am
Location: UK

Re: Files have stopped indexing

Postby popdefect » Tue Apr 29, 2014 6:44 pm

Hi Kenward,

I'm interested to explore the files indexing and startup behaviors you've described. Would you mind enabling verbose logging for X1, and then forward your logs after a day of usage? To enable verbose logging, simply add a new string value named "Verbosity" under the HKEY_CURRENT_USER hive here:

HKEY_CURRENT_USER\Software\X1 Search

Set the value of the Verbosity sting to "DEBUG".

I have not observed these issues in my environments, so I'm most curious to investigate.

Thanks for the report,
Alan Anderson

X1 Discovery
Director, QA
popdefect
 
Posts: 1
Joined: Fri Oct 07, 2011 10:36 am

Re: Files have stopped indexing

Postby Kenward » Wed Apr 30, 2014 1:03 am

Will do.

I can't explain the startup problem. That has always been there.

The indexing issue may have something to do with indexing a large stash of GMail. I limited the folders X1 should address, but indexing seems to prioritise GMail while postponing indexing of files.

It would be nice to be able to fine tune indexing so that I can make files the priority and tell it to deal with GMail when it has nothing else to do.
MK
X1 Search 8.6.1 - Build 6003fa (64-bit)
Windows 10 Pro 64-bit | Windows 10 Home 32-bit
No, I have nothing to do with X1, just a user since 2004.
Kenward
X1 Guru
X1 Guru
 
Posts: 4148
Joined: Tue Apr 20, 2004 2:35 am
Location: UK

Re: Files have stopped indexing

Postby Jogy » Wed Apr 30, 2014 8:39 am

Hi,

Have you paused GMail scanning?

One way to control which scanner is indexing is indexing now to select a saved search that originates from that scanner.
For example. selecting "All Files", or "Documents" or anything else under the Files node in the navigation tree should give priority to the Files scanner.

Jogy
Jogy
X1 Super User
X1 Super User
 
Posts: 387
Joined: Mon Oct 31, 2011 9:19 am


Return to X1® Search 8 Releases

Who is online

Users browsing this forum: No registered users and 14 guests