Page 1 of 1

8.3 Beta to 8.4 GA upgrade - says I already have latest ver

PostPosted: Sun Oct 19, 2014 3:35 am
by therev
Hi

I've got the 8.3 Beta installed, and see that 8.4 is now available as a full release with general availability.

When I check for updates, whether by running the installer or from within the beta, it says that I've already got the latest version even though the builds are different.

Or am I missing something?

Thanks!

Re: 8.3 Beta to 8.4 GA upgrade - says I already have latest

PostPosted: Sun Oct 19, 2014 3:47 am
by Kenward
therev wrote:...see that 8.4 is now available as a full release with general availability.


Where do you see that?

I have a question about the next release that may exp;lain why we don't see a new release.

Will 8.4 (or whatever the current beta turns into) be available to early adopters of 8.0 whose year's service is long gone? Or do we have to pay again?

Re: 8.3 Beta to 8.4 GA upgrade - says I already have latest

PostPosted: Sun Oct 19, 2014 4:36 am
by therev
Hi. Just searched, and I can't see it now, but there is a possibility that it was an excited head rush.

I may have seen 8.2.4 somewhere and my brain heard 8.4!

Re: 8.3 Beta to 8.4 GA upgrade - says I already have latest

PostPosted: Sun Oct 19, 2014 4:50 am
by Kenward
Easily done.

The last message I got – see recent discussions – was that there will be another 8.3 beta some time to fix some bugs. I hope it doesn't take too long.

One of these bugs – failure to preview email attachments – makes X1 8.3 all but unusable.

Re: 8.3 Beta to 8.4 GA upgrade - says I already have latest

PostPosted: Sun Oct 19, 2014 6:16 am
by therev
Hi. I'm not sure I get this problem ... so far as I can tell I can preview email attachments just fine (have tried doc/x and xls/x).

Am running build 5001lf (64 bit) with plugins 8.3.0.5292 (and Windows 8.1/Office 365 (2013)).

K

Re: 8.3 Beta to 8.4 GA upgrade - says I already have latest

PostPosted: Sun Oct 19, 2014 6:49 am
by Kenward
Preview of PDFs and other graphics don't work for me.

I reported it. Seems to be a known issue. Fix promised for next release.

X1 Discussion • View topic - No preview of attachments

Re: 8.3 Beta to 8.4 GA upgrade - says I already have latest

PostPosted: Sun Oct 19, 2014 8:23 am
by therev
Gotcha. PDF and jpgs also work fine for me. I'll count myself lucky this time!!!