Daily crashes with 8.4 continued after upgrade to 8.5

Bugs - Put em' here! We'll Squash them.

Moderator: Mods

Daily crashes with 8.4 continued after upgrade to 8.5

Postby something » Sat Jan 28, 2017 3:21 am

I was happy to see there's a new version thinking the annoying daily crashes may have been fixed. Well, no.

With 8.4 X1 Search would usually crash on the first "restore X1 UI from taskbar" after each Resume (on my notebook), but at least I was able to restart it. I submitted the logs online more than 10 times.

The upgrade to 8.5 wasn't smooth (the service was restarting on its own, I had to reboot the OS), and the stability got worse. Today after a crash I couldn't restart it, and now X1 search service isn't listed in the Windows services list.
I uninstalled X1 Search, downloaded the setup program from the Web and now my license can't be activated. Maybe it'll be better after I reboot, but it can be said that issues that have been persisting for years have not been solved or improved:
- License activation is still user-hostile
- UI crashes are frequent and log submissions don't seem to help the developers fix them
- X1 Service stability is inconsistent

Please don't develop new features until you make the s/w usable.

Edit: the usual reinstall procedure helped. I also disabled indexing of all extensions and then whitelisted a handful that I need.
something
 
Posts: 18
Joined: Tue Feb 11, 2014 4:06 am

Return to Bugs V8

Who is online

Users browsing this forum: No registered users and 3 guests