Page 1 of 1

External drive indexing not saved

PostPosted: Fri May 10, 2013 5:45 am
by hve
I have used X1 successfully for many years, with over 1.5 million files indexed on external drives.

I tried indexing several of these drives with the new V8 on my Windows 7 machine, but experienced a problem.

The older versions (V6.7.4) indexed external drives by creating a special "X1ID" file in a directory called "X1" on the external drive, so it was unique to the indexer.
That identifier would replace the drive id in the "path" column.

However, with V8, the drive id, not the identifier is in the path.

But the worst part is that the drive must remain plugged in for the indexed data for that drive to remain in the index.
If an external drive is removed after indexing, the X1 V8 removes all the data from that drive the next time the file indexer starts.

I tried different external drives, both hard drives and flash, but that made no difference.
The drives still work fine under V6.

Any help here?

Howard

Re: External drive indexing not saved

PostPosted: Fri May 10, 2013 7:13 am
by Kenward
This one came up in the beta tests.

Browse through to the end of this discussion:
viewtopic.php?f=58&t=5886

I have never been able to get an indexed USB to stick.

Re: External drive indexing not saved

PostPosted: Mon May 13, 2013 1:29 pm
by Rhonda
Greetings,

We have realized that external driving indexing is a problem and we're working on improvements in this area. I can check in with the team and make sure your particular issue is covered in those improvements.

Regards,
Rhonda