Page 1 of 1

Garmin Core Update Service causes problems with X1

PostPosted: Thu May 16, 2013 6:19 am
by Rhonda
We have confirmed that this service, which is used with several Garmin products -- is a process that is preventing X1 from working properly. Stopping this process will allow X1 to come back to life. This is due to the internal workings of the Garmin products and not something we have been able to find a way to workaround.

We will keep you posted as we learn more information.

Regards,

Rhonda

Re: Garmin Core Update Service causes problems with X1

PostPosted: Mon Jun 17, 2013 2:58 pm
by boblinthewild
Is there any update on this issue? I can't even install any of the Garmin utilities on the same system I have X1 Search installed on. This includes their USB utility and Garmin Connect. I get a dialogue saying something like, "it could take several minutes to complete the installation, click OK to proceed", but it never does complete and clicking 'OK' does nothing. Installs fine on other systems.

Re: Garmin Core Update Service causes problems with X1

PostPosted: Wed Jun 19, 2013 9:07 am
by Jogy
Hi,

the problem was reported to Garmin and there was a reply that "they have a fix in testing and expect it to be out in version 2.2.x "
we haven't got any update since then.

Until then the only way to make them run together is to configure all X1 executables to run with administrative privileges.

Jogy

Re: Garmin Core Update Service causes problems with X1

PostPosted: Thu Jun 20, 2013 10:49 am
by boblinthewild
Thanks Jogy. Just to be clear, are you saying to configure all .exe files in the X1 programs folder to run as Administrator?

Re: Garmin Core Update Service causes problems with X1

PostPosted: Thu Jun 20, 2013 12:21 pm
by Jogy
Hi,

For certain both X1.exe and X1ServiceHost.exe need to run with admin privileges to be able to connect ot each other, and also the X1Viewer.exe, WebImageExtractor.exe and X1ContentExtraction.exe too will need to run with admin privileges.

Only for X1MasterService.exe is not needed to set that option, because it already runs as a Windows service with privileges.

Jogy

Re: Garmin Core Update Service causes problems with X1

PostPosted: Thu Jun 20, 2013 3:22 pm
by boblinthewild
Thanks again Jogy. I'll give it a try and report back.

Re: Garmin Core Update Service causes problems with X1

PostPosted: Thu Jun 20, 2013 3:58 pm
by boblinthewild
That didn't work. I still can't install any of the Garmin software. Also, with all the X1 executables running in Administrator mode, Outlook wouldn't start, saying it couldn't get access to the .ost file. I guess I will wait for Garmin to come up with a solution.

Re: Garmin Core Update Service causes problems with X1

PostPosted: Tue Jul 02, 2013 3:20 am
by Slawer
What are the exact names of the Garmin processes that disturb X1 so I can kill? Thx

Re: Garmin Core Update Service causes problems with X1

PostPosted: Thu Aug 15, 2013 12:43 pm
by dvanvoorst
I've not been able to use X1 v8 for months now due to the "Unable to connect to the X1 service" error. So today I finally took the time to read these forums and saw the note about Garmin issue. Since I had installed Garmin about the time my X1 broke, I figured that was very likely the problem. When I opened Garmin Express it said that a program update was available - so I installed it. Immediately after doing that my X1 was able to start up normally!!!
So far the service error has not recurred. We'll see if that continues, but I just wanted to get on here and say that it's possible that the latest version of Garmin Express fixes the issue.
I'm still having issues installing the 8.0.1 update, but that's another issue...

Re: Garmin Core Update Service causes problems with X1

PostPosted: Thu Sep 12, 2013 4:07 am
by shiphen
Is this anything to do with the X1 Search v8.0 ==> v8.1 upgrade problem?

Basically as soon as I upgraded to 8.1 I lost my ability to index my Outlook files.
I have tried deactivating my copy of 8.1 and putting in my password and ID, but although it then say it will open up again in "paid mode" when it re-opens it is NOT in paid mode, and I can't index any emails at all.

ime is going by X1... and I am told this is a widespread problem... so please can you provide a fix even a temporary one, for you loyal customers !

Re: Garmin Core Update Service causes problems with X1

PostPosted: Thu Sep 12, 2013 6:25 am
by Kenward