V8.01 - Proxy problems continue

Bugs - Put em' here! We'll Squash them.

Moderator: Mods

V8.01 - Proxy problems continue

Postby csalsa » Thu Jun 06, 2013 7:51 pm

I ran the installer at work behind an authenticating proxy. The installer ran, downloaded the files and correctly installed X1 V8.01. So far no problem.

Today, I get a popup from X1 saying the installed application cannot authenticate as it does not detect an internet connection. Clicking on "OK" (the only option) closes X1. The application exits and is unusable.

It indicates that the proxy code in the X1 installer has not been correctly integrated into X1 V8.01.

Also, there is no warning of this issue until the popup and then X1 is unusable. I would suggest that X1 give, say, three days of grace, when it cannot re-authenticate every five days (I understand X1 re-authenticates every five days). During this time it presents a warning to the user so they either establish an Internet connection (say I am overseas or on-the road etc) or have time to contact X1 Support to get assistance. A "Stop. Do not pass Go. Go directly to exit" is not a friendly user experience.

PS. I ran the installer again and reinstalled X1. I am now able to run X1 again. This is a work around for now to re-install every five days.
csalsa
X1 Super User
X1 Super User
 
Posts: 180
Joined: Wed Jun 03, 2009 5:49 pm

Re: V8.01 - Proxy problems continue

Postby Rhonda » Fri Jun 07, 2013 7:25 am

I'd still like to see if we can nail down what the problem is. Can you email me again with your log files after running the diagnostics utility?

You shouldn't have to reinstall every 5 days because the call back has been stretched out to 2 weeks. Still we would really like to get to the bottom of your particular issue.

Rhonda


csalsa wrote:I ran the installer at work behind an authenticating proxy. The installer ran, downloaded the files and correctly installed X1 V8.01. So far no problem.

Today, I get a popup from X1 saying the installed application cannot authenticate as it does not detect an internet connection. Clicking on "OK" (the only option) closes X1. The application exits and is unusable.

It indicates that the proxy code in the X1 installer has not been correctly integrated into X1 V8.01.

Also, there is no warning of this issue until the popup and then X1 is unusable. I would suggest that X1 give, say, three days of grace, when it cannot re-authenticate every five days (I understand X1 re-authenticates every five days). During this time it presents a warning to the user so they either establish an Internet connection (say I am overseas or on-the road etc) or have time to contact X1 Support to get assistance. A "Stop. Do not pass Go. Go directly to exit" is not a friendly user experience.

PS. I ran the installer again and reinstalled X1. I am now able to run X1 again. This is a work around for now to re-install every five days.
Rhonda Rondeau
Product Manager
X1 Social Discovery
Rhonda
X1 Super User
X1 Super User
 
Posts: 223
Joined: Sat Feb 09, 2013 7:38 pm
Location: Pasadena, CA

Re: V8.01 - Proxy problems continue

Postby csalsa » Fri Jun 07, 2013 7:42 pm

I have uploaded the files as a new case. I hope it helps.

I draw your attention back to "soft" versus "hard" failures. Extending the period to two weeks reduces the problem but if there is no "soft" failure, that is, no warning with a transition period, I expect some people will re-experience the same problem again. Not everyone has an internet connection on demand all the time - just often have an internet connection.
csalsa wrote:Also, there is no warning of this issue until the popup and then X1 is unusable. I would suggest that X1 give, say, three days of grace, when it cannot re-authenticate every five days (I understand X1 re-authenticates every five days). During this time it presents a warning to the user so they either establish an Internet connection (say I am overseas or on-the road etc) or have time to contact X1 Support to get assistance. A "Stop. Do not pass Go. Go directly to exit" is not a friendly user experience.


As the proxy connection works through the installer, the connection problem with X1 Search should be easily addressed.
csalsa
X1 Super User
X1 Super User
 
Posts: 180
Joined: Wed Jun 03, 2009 5:49 pm

Re: V8.01 - Proxy problems continue

Postby Rhonda » Sat Jun 08, 2013 6:45 am

csalsa wrote:I have uploaded the files as a new case. I hope it helps.

I draw your attention back to "soft" versus "hard" failures. Extending the period to two weeks reduces the problem but if there is no "soft" failure, that is, no warning with a transition period, I expect some people will re-experience the same problem again. Not everyone has an internet connection on demand all the time - just often have an internet connection.
csalsa wrote:Also, there is no warning of this issue until the popup and then X1 is unusable. I would suggest that X1 give, say, three days of grace, when it cannot re-authenticate every five days (I understand X1 re-authenticates every five days). During this time it presents a warning to the user so they either establish an Internet connection (say I am overseas or on-the road etc) or have time to contact X1 Support to get assistance. A "Stop. Do not pass Go. Go directly to exit" is not a friendly user experience.


As the proxy connection works through the installer, the connection problem with X1 Search should be easily addressed.


Do you mind sending the case number directly too me? I want to make sure our developers get to it first thing Monday am. Thanks for your help :)
Rhonda Rondeau
Product Manager
X1 Social Discovery
Rhonda
X1 Super User
X1 Super User
 
Posts: 223
Joined: Sat Feb 09, 2013 7:38 pm
Location: Pasadena, CA


Return to Bugs V8

Who is online

Users browsing this forum: No registered users and 17 guests

cron