X1 Search 8.2.1 and X1OutlookService32 fails

Bugs - Put em' here! We'll Squash them.

Moderator: Mods

X1 Search 8.2.1 and X1OutlookService32 fails

Postby crethier » Sat Jun 14, 2014 9:08 am

Dear All

If anyone has a fix for this I would be most grateful.
I am running X1 search 8.2.1 (build 5001hb, in evaluation mode) and Outlook2010 (32 bit) on a Win8.1 64 bit box. File indexing works fine. However, I cannot index any Outlook items; in fact, I cannot even select Outlook data sources. When I try to start or edit indexing of any Outlook item, I get the "There was an error reading from the pipe: The pipe has been ended. (109, 0x6d)" error.

Things I have tried
- install X1 as both 32 bit and 64 bit versions
- Repair .net installation
- Create new mail profile and load that profile in Outlook before launching X1

The X1 install was clean; however, as you can see from the excerpt from the X1OutlookService32 log below, there is some kind of a problem between X1 and the MAPI interface.

The search client looks great & I would like to purchase it, but it is not useful to me if I cannot index outlook items (I have many large pst files I want to be able to search).

Thanks in advance for any help



12 Jun 2014 20:04:48,471 [1] INFO X1OutlookService32 - Starting X1OutlookService32...
12 Jun 2014 20:04:48,474 [1] INFO OutlookUtils - Outlook version 14 is installed.
12 Jun 2014 20:04:48,477 [1] INFO X1OutlookService32 - Using service running mutex: X1OutlookService32_running_258855244
12 Jun 2014 20:04:48,492 [1] INFO X1OutlookService32 - Listening on endpoint: net.pipe://localhost/X1/X1OutlookService32_258855244
12 Jun 2014 20:04:48,594 [1] INFO X1OutlookService32 - Opening startup event: X1OutlookService32_startup_258855244
12 Jun 2014 20:04:48,597 [1] INFO X1OutlookService32 - Opening shutdown event: X1OutlookService32_shutdown_258855244
12 Jun 2014 20:04:48,598 [1] INFO X1OutlookService32 - Opening client running mutex: {69A842A8-1394-4132-A579-88E66D9C2C89}-299272965
12 Jun 2014 20:04:48,598 [1] INFO X1OutlookService32 - Waiting for shutdown event
12 Jun 2014 20:04:49,020 [MAPIThread] INFO MAPIService - Loaded: C:\Program Files (x86)\X1 Search\Plugins\MAPI32\X1OutlookProvider32.dll
12 Jun 2014 20:04:49,204 [MAPIThread] ERROR X1OutlookService32 - Exception in MAPI
System.Runtime.InteropServices.COMException (0x80004004): Operation aborted (Exception from HRESULT: 0x80004004 (E_ABORT))
at System.Runtime.InteropServices.Marshal.ThrowExceptionForHRInternal(Int32 errorCode, IntPtr errorInfo)
at System.Runtime.InteropServices.Marshal.ThrowExceptionForHR(Int32 errorCode)
at X1OutlookProvider.InstanceProxy.InitializeX1Mapi(String mpParams, String logLevel)
at X1.Outlook.Service.MAPI.MAPIService.Init()
at X1.Outlook.Service.OutlookService.<>c__DisplayClass7.<Create>b__6()
at X1.Outlook.Service.OutlookService.<>c__DisplayClass4.<ExecuteMAPICode>b__0()
12 Jun 2014 20:04:49,211 [MAPIThread] ERROR X1OutlookService32 - Shutting down due to unhandled exception
crethier
 
Posts: 2
Joined: Sat Jun 14, 2014 8:52 am

Re: X1 Search 8.2.1 and X1OutlookService32 fails

Postby Kenward » Mon Jun 16, 2014 1:53 am

Sound like you need some official help. Try submitting a support ticket:

http://www.x1.com/support/x1_search_submit_case.html

You will see that it has a slot for "evaluation customers".
MK
X1 Search 8.6.1 - Build 6003fa (64-bit)
Windows 10 Pro 64-bit | Windows 10 Home 32-bit
No, I have nothing to do with X1, just a user since 2004.
Kenward
X1 Guru
X1 Guru
 
Posts: 4137
Joined: Tue Apr 20, 2004 2:35 am
Location: UK

Re: X1 Search 8.2.1 and X1OutlookService32 fails

Postby crethier » Mon Jun 16, 2014 5:14 am

Thanks Kenward. I did not realize that was an option for evaluation versions. Have submitted the ticket.
crethier
 
Posts: 2
Joined: Sat Jun 14, 2014 8:52 am


Return to Bugs V8

Who is online

Users browsing this forum: No registered users and 10 guests

cron