Page 1 of 1

X1 8.2.1 not fully indexing Outlook mail

PostPosted: Wed Jul 16, 2014 6:50 pm
by SDorn
I've just installed X1 on my primary PC (Win8.1) and I'm having trouble getting it to fully index my email. I have 12,000+ emails but X1 is only showing 3700 of them. Trying to force indexing just runs for 1sec and says done. I even deleted the index and restarted from scratch but no improvement. Below is an image showing the issue. Is there any way to get all items indexed?

Image

Re: X1 8.2.1 not fully indexing Outlook mail

PostPosted: Thu Jul 17, 2014 8:34 pm
by SDorn
OK, I found the answer in another forum...

Outlook 2013 has a new "feature" where it only stores the last year's email locally by default, causing X1 to only index email < 1yr old. To keep all mail the procedure is as follows:

1) Open Account Settings
- From Outlook 2013 it is under File/Account Settings
- From Windows it is under Start/Mail/Email Accounts

2) Select your mail account and click the Change... button

3) Move the "Mail to keep offline" slider all the way right to the All position

Image

Re: X1 8.2.1 not fully indexing Outlook mail

PostPosted: Fri Jul 18, 2014 1:34 am
by Kenward
Well found.

I assume that Outlook 2013 is Office 365. In which case, your discovery may solve other issues that have come up here.

I wonder if there are any other settings like that in the entrails of Office 365 that people should investigate