Page 1 of 1

NEAR causing X1 Service to crash

PostPosted: Mon Sep 29, 2014 10:44 am
by billo
Using NEAR in search causes an "X1 Connection Lost" every time I use it. Not something I've used much lately and it took me some time to realize that NEAR was the cause. It is consistent and it has been a problem between versions.

Have selected the "A restart may fix this problem. Would you like to restart X1?" every time the error appears.

Have rebooted computer. Can still recreate the problem.

Running X1 8.2.4
Windows 7 Pro

Thanks,
Bill

Re: NEAR causing X1 Service to crash

PostPosted: Mon Sep 29, 2014 11:34 am
by Kenward
Is this in any search? Or just a specific saved search?

Re: NEAR causing X1 Service to crash

PostPosted: Fri Oct 10, 2014 8:37 am
by Jerald Metz
Hi Bill,

As Kewnard mentioned, it would be helpful if we could get some more detail on the use case that causes this so we can try to reproduce the issue in house.

1. Can you provide sample searches that always cause the crash
2. Does this happen on all search types (Everything > All, Everything > Email, Outlook Email, Files, etc.)?

Also, could you please run our diagnostic tool shortly after producing this crash a few times? Steps are below:

1. Download: http://support.x1.com/cs/x1s_diagnostic_tool.exe
2. Double-click the downloaded "x1s_diagnostic_tool.exe" file to run (Users with UAC turned on should right-click the file and select Run as administrator)
3. A Windows Explorer window will open when the tool has finished (this may take a minute).
4. Locate the ZIP file in the newly created x1supportfiles directory, and email to me

Thanks much!

Re: NEAR causing X1 Service to crash

PostPosted: Mon Oct 20, 2014 12:28 pm
by billo
Apologies for not checking the board sooner. Been busy at work.

I generally just keep the search type on "Everything > All" and that is where the problem has occurred. I don't have a sample search that always causes a crash.

What's a bit frustrating is after months of having this problem I recreated it 3 times this morning under Everything > All. I couldn't remember if I'd ever tried NEAR with type Documents so I tried it and it worked fine. Then I did a search under Email using NEAR and it worked fine. Then I went back to "Everything > All" and used NEAR and the results popped right up. So, it works for the moment but no idea why. Will do some more experimenting later. It's a good thing I like computers.

Also, I rarely use saved searches because all of my searches are random...

Thanks,
Bill

Re: NEAR causing X1 Service to crash

PostPosted: Mon Oct 20, 2014 1:27 pm
by Kenward
billo wrote:Also, I rarely use saved searches because all of my searches are random...


But there may be some underlying patterns that would make life easier for you.

Took me time to work out what they might do.

I am still grappling with confederated searches, another option, even though they have been around for some time.

They've thrown another technical term for searches into the fray since then. I have no idea what a "Brokered Search" is about.

Re: NEAR causing X1 Service to crash

PostPosted: Mon Oct 20, 2014 1:30 pm
by Jerald Metz
Kenward,

Brokered Searches refer to any search in X1 that does not use a local index. This includes X1 Rapid Discovery and SharePoint.

For those connectors we leverage the existing indexes and broker the search externally, then bring the results into the X1 interface in a way that allows users to do fast-as-you-type search and refinement.

Hope this clears up that question.

Thanks!

Re: NEAR causing X1 Service to crash

PostPosted: Mon Oct 20, 2014 1:34 pm
by Jerald Metz
billo,

If we can get a reliably reproducible use-case, it will make it much easier for us to diagnose.

Either way, the next time it happen, please generate diag logs per my original post and email them to me directly.

Thanks!

Re: NEAR causing X1 Service to crash

PostPosted: Tue Oct 21, 2014 7:06 pm
by billo
Jerald,

Thanks and I will. I'm planning on upgrading to 8.3 tomorrow and maybe that will resolve the problem. If it does popup again I'll general the logs and send them to you.

Bill

Re: NEAR causing X1 Service to crash

PostPosted: Tue Oct 21, 2014 7:14 pm
by Jerald Metz
Great!

Thanks much!