Page 1 of 1

Can't Open GUI 8.3.0.5309

PostPosted: Fri Nov 07, 2014 4:32 pm
by bobuser
Longest time user - now on 8.3.0.5309 - can't Open X1 at all...it's running - icon in taskbar - but nothing on screen - GUI is on vacation...

Any hints as to where any settings may be to bring back the GUI? (couldn't see this in the reg keg or all the various ini/config files).

Only 1 monitor - Win2008R2 - running in VM - all has been fine with previous versions. Haven't yet de-installed, but may need to.

All X1 processes are running - just can't see the GUI - which is a slight problem.

**Edit - Ok, complete de-install and re-install and GUI is back...but think this is a bug...as this is a server OS, not much at all changes on it at all..and nothing recently that I can think of.

Re: Can't Open GUI 8.3.0.5309

PostPosted: Sat Nov 08, 2014 3:14 am
by Kenward
bobuser wrote:**Edit - Ok, complete de-install and re-install and GUI is back...but think this is a bug...


I'd be more inclined to go along with your earlier theory about a screwed up configuration file. I've seen similar oddities in the past.

I guess you could call it a bug in that X1 is writing bad data to the file, but it could also be a Windows thing.

The xml files that X1 uses to store stuff can do strange things. For example, they can save the wrong data for the position of the UI window. So it can start off-screen or in an impossible position. Sometimes you can get this back simply by "cascading" the windows. But at times I have had to edit, or even delete (rename), the xml file.

I don't recall doing this in 8.X, but it looks like the data is in the UIconfig.xml file. Probably the settings for MainWindowX and MainWindowY.

If you want to save the data for a recovery should this ever happen again, you could create a copy of UIconfig.xml for reference.

Re: Can't Open GUI 8.3.0.5309

PostPosted: Sat Nov 08, 2014 4:29 pm
by bobuser
Re-install lasted only 1 day. Back again, no Gui.

Thanks, that XML does have the screen co-ords - and they look fine. This box is a demo box, VM, and nothing at all has happened with it. I'm happy for a remote session with X1 folks if they want to have a look around.

I may just roll back to an older stable version if I can find one...

**Edit. Err, right, you can't downgrade - X1 forcing everyone onto their latest, and possible (not) greatest version...

Re: Can't Open GUI 8.3.0.5309

PostPosted: Sun Nov 09, 2014 3:07 am
by Kenward
You fixed it, so why do you want someone to get into your PC? Unless it is reproducible, that would probably show nothing.

As to using old versions, this is another consequence of the X1 delivery regime. The company simply will not deliver the whole installation package as a download. You have to go through its "stub and retrieve" process.

I usually try to grab copies of the download files (the msi and cab files) for later use. X1 may frown on this practice, but I paid for the software and should be free to use it as I see fit.

Re: Can't Open GUI 8.3.0.5309

PostPosted: Sun Nov 09, 2014 3:22 am
by bobuser
I fixed it only for 1 day - it's come back again - No Gui....

Now, I've reinstalled yet again (and kept all config files for some stupid thought that maybe X1 would be interested - Hah!) - see if it stays this way.

Re: Can't Open GUI 8.3.0.5309

PostPosted: Sun Nov 09, 2014 5:22 am
by Kenward
Your best bet is to submit a support request.

Re: Can't Open GUI 8.3.0.5309

PostPosted: Mon Nov 10, 2014 6:56 pm
by Jerald Metz
Hi bobuser,

It's hard to say what might be preventing the UI from appearing.

As Kenward suggested, best bet is to open a support ticket and provide log files so we can dig in.

You can open a support ticket here:

http://www.x1.com/support/x1_search.html

Thanks!

Re: Can't Open GUI 8.3.0.5309

PostPosted: Tue Nov 11, 2014 5:49 pm
by bobuser
Ok - thanks - will do - I reinstalled again - and it's OK (sort of) so far.

I can't realign reading pane size now (can realign columns OK, but reading pane size is fixed and can't be resized) - but at least it's functioning. So, happy to have this compromise.

I posted here as I thought that was the point of this forum.

In the meantime, now have a new issue - X1 launches, but comes up with an X1 message saying the PC time is not sync'd - please connect to these NTP servers. What the heck? The time is correct. Possibly requires it's own post or support ticket issue. That was after applying all of MS Update Tues patches...but, another reboot - and it's now behaving itself again...no message displayed and is functioning Ok.

Re: Can't Open GUI 8.3.0.5309

PostPosted: Wed Nov 12, 2014 12:32 pm
by Kenward
bobuser wrote:I posted here as I thought that was the point of this forum.


Not really. This has never been the preferred channel for official support. As I understand it, this forum started as essentially a place for user-to-user self-support, which is now common practice throughout the software industry.

The X1 folks sort of blew that notion out of the water by being much more actively involved than the staff on other forums.

While you can get help here with problems, the message has always been that you should use the official support channels if you hit something really sticky. You are supposed to pay for that help, but somehow this seems to slip from the X1 memory, possibly because the techies there almost seem to enjoy grappling with new challenges and don't like it when their software does something cranky.