8.3.1.1 64bits : wrong acccent display with html files !

Bugs - Put em' here! We'll Squash them.

Moderator: Mods

8.3.1.1 64bits : wrong acccent display with html files !

Postby bejuit » Thu Jan 08, 2015 9:03 am

Hello,
I use X1 search since a few days. I am french using the english version of X1 8.3.1.1 64bits (Biuld 5003az).

And I have noticed that text is garbled for html files when there are accents.
Example : "répondre" instead of "répondre".

I have seen that there is an option "ignore accents in characters". Alas I don't understand this option well and I have found nothing in the help files.

Thanks in advance ;)
bejuit
 
Posts: 6
Joined: Thu Jan 08, 2015 8:52 am

Re: 8.3.1.1 64bits : wrong acccent display with html files !

Postby Kenward » Thu Jan 08, 2015 12:41 pm

bejuit wrote:I have seen that there is an option "ignore accents in characters". Alas I don't understand this option well and I have found nothing in the help files.


Are you saying you haven't found this option?

It is in X1 Options, Index.
MK
X1 Search 8.5.2 - Build 6001si (64-bit)
Windows 10 Pro 64-bit | Windows 10 Home 32-bit
No, I have nothing to do with X1, just a user since 2004.
Kenward
X1 Guru
X1 Guru
 
Posts: 4107
Joined: Tue Apr 20, 2004 2:35 am
Location: UK

Re: 8.3.1.1 64bits : wrong acccent display with html files !

Postby Kenward » Thu Jan 08, 2015 2:37 pm

bejuit wrote:I have seen that there is an option "ignore accents in characters". Alas I don't understand this option well and I have found nothing in the help files.


Are you saying you haven't found this option?

It is in X1 Options, Index.

Maybe there is a problem because your PC thinks in French but X1 works in English and the entente cordiale has broken down.
MK
X1 Search 8.5.2 - Build 6001si (64-bit)
Windows 10 Pro 64-bit | Windows 10 Home 32-bit
No, I have nothing to do with X1, just a user since 2004.
Kenward
X1 Guru
X1 Guru
 
Posts: 4107
Joined: Tue Apr 20, 2004 2:35 am
Location: UK

Re: 8.3.1.1 64bits : wrong acccent display with html files !

Postby bejuit » Fri Jan 09, 2015 12:41 am

Thanks for your reply.

I have found where the option is. In fact what I am not sure is what it does (Also as it will rebuild my index from scratch, so I am cautious !) ?

Here are my tests so far without the option "ignore accents in characters" NOT checked :

Now: I can do searches with keyword containing accents (X1 finds the keyword in all kind of files (pdf, txt, htm, html ...) :
The results are properly displayed in the preview pane with most files (pdf, txt,...here the keyword with accent is highlighted automatically when I click on a file) but not with htm and html files. For those last files I have to find manually the keyword with CTRL+F : and search for "only_the_last_part_of_the_keyword_without_accent" in order to highlight part of the keyword !!

Now if I checked the option "ignore accents in characters" :
Will my previous example become :
"repondre" (no accent) in displayed results. And keyword without accent highlighted automatically in the results pane ?
My guess is that I won't be able to do keyword searches with accent anymore ?
Am I right ?

Maybe there is a problem because your PC thinks in French but X1 works in English and the entente cordiale has broken down.

In fact I don't remember if I had the option to choose languages for instance between english or french when I installed the X1 ! Maybe someone knows ? IMHO, if coding is properly done, it should influence only the GUI display options not the Index content ?

Many thanks in advance ;)
Last edited by bejuit on Fri Jan 09, 2015 6:40 am, edited 3 times in total.
bejuit
 
Posts: 6
Joined: Thu Jan 08, 2015 8:52 am

Re: 8.3.1.1 64bits : wrong acccent display with html files !

Postby Kenward » Fri Jan 09, 2015 5:55 am

bejuit wrote:I have found where the option is. In fact what I am not sure is what it does (Also as it will rebuild my index from scratch, I am cautious !) ?


The help file/FAQ says:

Ignore accents in characters displays characters in plain text.


So it should eliminate the mess that you see.

You may well have to reindex. But if that is what it takes to fix your problem, there is not other choice.

The rest of your questions are beyond my knowledge.

The issue of accents is a long running one with X1. You may find it worthwhile to search the forum for earlier discussions.

Do you always see this behaviour? Is it in all files, email and documents? If it is only occasional, then maybe it is down to the fonts and what you have installed on the PC.
MK
X1 Search 8.5.2 - Build 6001si (64-bit)
Windows 10 Pro 64-bit | Windows 10 Home 32-bit
No, I have nothing to do with X1, just a user since 2004.
Kenward
X1 Guru
X1 Guru
 
Posts: 4107
Joined: Tue Apr 20, 2004 2:35 am
Location: UK

Re: 8.3.1.1 64bits : wrong acccent display with html files !

Postby bejuit » Fri Jan 09, 2015 6:27 am

Hi again,

Here are the results of my tests on the computer of a relative (windows 764bit is in french) :
First there is no option to choose the GUI language (english or french) when installing X1.

If I check the option "ignore accents in characters" :
Keyword : "répondre" finds correctly all documents containing "répondre". ;)
Keyword: "repondre" finds "repondre" and "répondre" !

Alas I have the same problem for html files : words with accents are not correctly displayed in the result pane ! ;(


Thanks for your help anyway, I think I will keep the option "ignore accents in characters" unchecked for my part as it would not change much for me !
bejuit
 
Posts: 6
Joined: Thu Jan 08, 2015 8:52 am


Return to Bugs V8

Who is online

Users browsing this forum: No registered users and 28 guests