Keeps reverting to 8.3

Bugs - Put em' here! We'll Squash them.

Moderator: Mods

Keeps reverting to 8.3

Postby Kenward » Thu Nov 05, 2015 4:02 am

Something strange has happened to my installation.

It keeps popping up with an "Update available" window, although I have applied the update.

Then if I look at the About window it says 8.3.3 build 5003fx.

Image

Ask it to look for uodates, it says 8.4 is there. So I ask it to update, and it says no update available.

All the files in the X1 program folder have the expected date, 2015-10-27.

So it looks like I have 8.4 installed and it is lying to me.
MK
X1 Search 8.6.1 - Build 6003fa (64-bit)
Windows 10 Pro 64-bit | Windows 10 Home 32-bit
No, I have nothing to do with X1, just a user since 2004.
Kenward
X1 Guru
X1 Guru
 
Posts: 4149
Joined: Tue Apr 20, 2004 2:35 am
Location: UK

Re: Keeps reverting to 8.3

Postby Kenward » Thu Nov 05, 2015 4:17 am

I have just retrieved and run the files again.

The "bootstrapper" stops because it thinks X1 is already up to date.

So I install using the 64 bit msi file. Help About tells me that it has installed 8.4 build 5003ow.

Reboot, and Help About tells me that I am back on 8.3.3.
MK
X1 Search 8.6.1 - Build 6003fa (64-bit)
Windows 10 Pro 64-bit | Windows 10 Home 32-bit
No, I have nothing to do with X1, just a user since 2004.
Kenward
X1 Guru
X1 Guru
 
Posts: 4149
Joined: Tue Apr 20, 2004 2:35 am
Location: UK

Re: Keeps reverting to 8.3

Postby Jogy » Thu Nov 05, 2015 4:32 am

Hi,

Can you check if by any chance you have X1 installed in two locations? I can't explain in any other way why before reboot the Help About will show 8.4, and after reboot it will show 8.3.3.
Also, you can check the properties of the file x1.exe and on the details page see what version is set.

Jogy
Jogy
X1 Super User
X1 Super User
 
Posts: 398
Joined: Mon Oct 31, 2011 9:19 am

Re: Keeps reverting to 8.3

Postby Kenward » Thu Nov 05, 2015 5:28 am

My first thought was that it was installed twice. But, no, it isn't.

The X1 file is "Product version 8.4.0.7417".

So I have 8.4 installed but "About" says 8.3.3.
MK
X1 Search 8.6.1 - Build 6003fa (64-bit)
Windows 10 Pro 64-bit | Windows 10 Home 32-bit
No, I have nothing to do with X1, just a user since 2004.
Kenward
X1 Guru
X1 Guru
 
Posts: 4149
Joined: Tue Apr 20, 2004 2:35 am
Location: UK

Re: Keeps reverting to 8.3

Postby Jogy » Thu Nov 05, 2015 5:44 am

Hi,

Can you also check the date and the version of the file x1.common.dll .. and also check if there is a duplicate of that file somewhere ..

Jogy
Jogy
X1 Super User
X1 Super User
 
Posts: 398
Joined: Mon Oct 31, 2011 9:19 am

Re: Keeps reverting to 8.3

Postby Kenward » Fri Nov 06, 2015 5:30 am

Created 27 ‎October ‎2015, ‏‎10:12:20

There are two copies:

C:\Program Files\X1 Search\Plugins\X1.Common.dll
C:\Program Files\X1 Search\X1.Common.dll

Same dates and file versions but different sizes.
MK
X1 Search 8.6.1 - Build 6003fa (64-bit)
Windows 10 Pro 64-bit | Windows 10 Home 32-bit
No, I have nothing to do with X1, just a user since 2004.
Kenward
X1 Guru
X1 Guru
 
Posts: 4149
Joined: Tue Apr 20, 2004 2:35 am
Location: UK

Re: Keeps reverting to 8.3

Postby Jogy » Fri Nov 06, 2015 5:43 am

Hi,

can you try, while both the UI and the service are stopped, to rename one of those files, for example the one in Plugins and copy the other file so that X1 does not crash. The start X1 and check the version.
If it still 8.3.3, exit, restore the renamed file and rename the other, and again check the reported version.

Jogy
Jogy
X1 Super User
X1 Super User
 
Posts: 398
Joined: Mon Oct 31, 2011 9:19 am

Re: Keeps reverting to 8.3

Postby Kenward » Sat Nov 07, 2015 5:26 am

I first made the "for example" change you suggested, renamed the file in plugins and copied over the other.

It is now showing the correct version, 8.4.

The next move will be to reboot to see if it sticks.
MK
X1 Search 8.6.1 - Build 6003fa (64-bit)
Windows 10 Pro 64-bit | Windows 10 Home 32-bit
No, I have nothing to do with X1, just a user since 2004.
Kenward
X1 Guru
X1 Guru
 
Posts: 4149
Joined: Tue Apr 20, 2004 2:35 am
Location: UK

Re: Keeps reverting to 8.3

Postby Kenward » Sat Nov 07, 2015 7:00 am

Turns out that neither variation works.

The program always reverts to claiming that it is X1 8.3.3.
MK
X1 Search 8.6.1 - Build 6003fa (64-bit)
Windows 10 Pro 64-bit | Windows 10 Home 32-bit
No, I have nothing to do with X1, just a user since 2004.
Kenward
X1 Guru
X1 Guru
 
Posts: 4149
Joined: Tue Apr 20, 2004 2:35 am
Location: UK

Re: Keeps reverting to 8.3

Postby Jogy » Sat Nov 07, 2015 8:52 am

Hi,

can you install the Sysinternals tool Process Explorer : https://technet.microsoft.com/en-us/sys ... 96653.aspx
Start it with administrator rights, and when X1 is running, in the main Process Explorer window locate X1.exe.
Then right-click and select Properties. The dialog should have a tab .NET Assemblies. It will show the actual assemblies loaded by X1. Find X1.Common and see from which path is it loaded.
Also, if you hold the mouse over it, it will show a tooltip with the file version.

Jogy
Jogy
X1 Super User
X1 Super User
 
Posts: 398
Joined: Mon Oct 31, 2011 9:19 am


Return to Bugs V8

Who is online

Users browsing this forum: No registered users and 47 guests