Quick Launch Keyboard Shortcut Disappeared

This forum is to discuss general things about X1.

Moderator: Mods

Quick Launch Keyboard Shortcut Disappeared

Postby thinkstorm » Tue Jun 17, 2008 6:02 am

Hello,

The options dialog at "Keyboard Shortcuts" does not show any drop-down box anymore for "Keyboard Shortcut for Launching X1 from the Desktop"

Is there a .ini entry I could add? I set it to CTRL-ALT-X, no other program is using that shorcut.

Cheers,
Thorsten
Cheers,
Thorsten Claus
www.thinkstorm.com
thinkstorm
 
Posts: 38
Joined: Thu Apr 22, 2004 11:23 pm

Postby Kenward » Tue Jun 17, 2008 7:05 am

Which version of X1 you use?

Have you tried a "Repair" or reinstalling X1 on top of itself?

Many of the settings are in the file barsettings.ini, others are in X1Config.ini.

The location of these depends on your operating system, so it is best just to search for them.

In Vista they are here:

C:\Users\{username}\AppData\Local\X1 Desktop Search\
MK
X1 Search 8.6.1 - Build 6003fa (64-bit)
Windows 10 Pro 64-bit | Windows 10 Home 32-bit
No, I have nothing to do with X1, just a user since 2004.
Kenward
X1 Guru
X1 Guru
 
Posts: 4148
Joined: Tue Apr 20, 2004 2:35 am
Location: UK

Postby thinkstorm » Tue Jun 17, 2008 8:21 am

Yes, I tried to repair, no luck.

The hotkey section within the .ini script only shows the access keys to email. files, documents, etc. searches...

Any other idea?

Can anyone look into his/her .ini file for the shortcut code for CTRL-ALT-L?
Cheers,
Thorsten Claus
www.thinkstorm.com
thinkstorm
 
Posts: 38
Joined: Thu Apr 22, 2004 11:23 pm

Postby Tod » Tue Jun 17, 2008 12:17 pm

Is it possible that you deleted your X1 shortcut out of the Start menu and/or are not launching it on startup? I have heard that the shortcut key will not work in this case, but I have not had a chance to try it. Here are some things to look for:
1) HKLM/Software/X1 Desktop Search/ProgramMenuShortcutPath = C:\Documents and Settings\<username>\Start Menu\Programs\Startup\
2) HKLM/Software/X1 Desktop Search/ProgramMenuShortcutFilename = X1.lnk
3) X1.lnk must exist in the above path on disk and have a Ctrl+Alt shortcut key assigned in it when you view its properties.
4) you must also have the "Load X1 at startup" checked in the Basic page of Options dialog.
Tod
X1 Rep
X1 Rep
 
Posts: 178
Joined: Thu Apr 07, 2005 8:26 pm
Location: Pasadena, CA

Postby thinkstorm » Sat Jun 21, 2008 7:06 pm

Yep, that's the case - I deleted the .LNK shortcut in the startup menu. I saw that it had the CTRL-ALT-X keyboard shortcut attached to it (I changed it from the CTRL-ALT-L), but it did not work. I only load the system tray icon by default.

X1 was loading *once* when it was invoked through the keyboard shortcut the first time, but that was it - any subsequent usage of the shortcut key didn't work anymore, and as I said, the options setting was gone.

I found a work around through AutoHotkey (http://www.autohotkey.com):
Code: Select all
^!x::
   DetectHiddenWindows, On
   SetTitleMatchMode, 1
   WinGet, hwnd, ID, X1 - ahk_class TApplication
   If hwnd
   {
      WinRestore, ahk_id %hwnd%
      ;SendMessage, 0x112, 0xf120,,,ahk_id %hwnd%
   } else {
      Run, C:\Program Files\X1\X1.exe
   }
Return


Cheers,
Thorsten
Cheers,
Thorsten Claus
www.thinkstorm.com
thinkstorm
 
Posts: 38
Joined: Thu Apr 22, 2004 11:23 pm


Return to General Discussion

Who is online

Users browsing this forum: No registered users and 24 guests