X1 8.2.1 not fully indexing Outlook mail

Bugs - Put em' here! We'll Squash them.

Moderator: Mods

X1 8.2.1 not fully indexing Outlook mail

Postby SDorn » Wed Jul 16, 2014 6:50 pm

I've just installed X1 on my primary PC (Win8.1) and I'm having trouble getting it to fully index my email. I have 12,000+ emails but X1 is only showing 3700 of them. Trying to force indexing just runs for 1sec and says done. I even deleted the index and restarted from scratch but no improvement. Below is an image showing the issue. Is there any way to get all items indexed?

Image
SDorn
 
Posts: 3
Joined: Wed Jul 16, 2014 6:33 pm

Re: X1 8.2.1 not fully indexing Outlook mail

Postby SDorn » Thu Jul 17, 2014 8:34 pm

OK, I found the answer in another forum...

Outlook 2013 has a new "feature" where it only stores the last year's email locally by default, causing X1 to only index email < 1yr old. To keep all mail the procedure is as follows:

1) Open Account Settings
- From Outlook 2013 it is under File/Account Settings
- From Windows it is under Start/Mail/Email Accounts

2) Select your mail account and click the Change... button

3) Move the "Mail to keep offline" slider all the way right to the All position

Image
SDorn
 
Posts: 3
Joined: Wed Jul 16, 2014 6:33 pm

Re: X1 8.2.1 not fully indexing Outlook mail

Postby Kenward » Fri Jul 18, 2014 1:34 am

Well found.

I assume that Outlook 2013 is Office 365. In which case, your discovery may solve other issues that have come up here.

I wonder if there are any other settings like that in the entrails of Office 365 that people should investigate
MK
X1 Search 8.6.1 - Build 6003fa (64-bit)
Windows 10 Pro 64-bit | Windows 10 Home 32-bit
No, I have nothing to do with X1, just a user since 2004.
Kenward
X1 Guru
X1 Guru
 
Posts: 4148
Joined: Tue Apr 20, 2004 2:35 am
Location: UK


Return to Bugs V8

Who is online

Users browsing this forum: No registered users and 16 guests