8.3.0.5309: Connection with the x1 service has been lost

Bugs - Put em' here! We'll Squash them.

Moderator: Mods

8.3.0.5309: Connection with the x1 service has been lost

Postby OliverHorn » Thu Oct 23, 2014 12:28 am

Hi,

after the automatic update at 22.10.2014 i get every minute following error message, that connection to the x1 service is lost.
Working with this version is not possible!

With the former version, everything works fine.
Is there any possibility to get back the former version?

Could you please provide a link to it?

Thanks a lot,
Oliver
OliverHorn
 
Posts: 1
Joined: Thu Oct 23, 2014 12:22 am

Re: 8.3.0.5309: Connection with the x1 service has been lost

Postby jsbellin76 » Fri Oct 31, 2014 8:51 am

I get the same problem on 8.3. After installing 8.3, things work fine for a few days, then opening the Email tab in 8.3 produces "Connection with X1 Server has been lost. A restart may fix this problem...". Restarting X1 or rebooting doesn't work. Re-installing does work.

Configuration: Office 2013, Windows 7 in a Parallels virtual machine on a mid-2011 MacBook Air running Yosemite.

I too would like to go back to 8.2.
jsbellin76
 
Posts: 6
Joined: Sat Jun 22, 2013 2:48 pm

Re: 8.3.0.5309: Connection with the x1 service has been lost

Postby Jerald Metz » Tue Nov 04, 2014 12:36 pm

Hello,

We've had a number of users report that a repair of Outlook has solved this problem for them.

If this does not help, please create a support ticket here:

http://www.x1.com/support/x1_search_submit_case.html

Thanks!
Jerald Metz
Product Manager, X1 Search 8

Please feel free to reach me directly at jmetz (at) x1 (dot) com
Jerald Metz
X1 Super User
X1 Super User
 
Posts: 299
Joined: Mon Sep 27, 2004 4:22 pm
Location: Pasadena, CA

Re: 8.3.0.5309: Connection with the x1 service has been lost

Postby Kenward » Tue Nov 04, 2014 2:43 pm

Is that a repair of Outlook? Or a scanpst repair of the PST files? Or both?
MK
X1 Search 8.6.1 - Build 6003fa (64-bit)
Windows 10 Pro 64-bit | Windows 10 Home 32-bit
No, I have nothing to do with X1, just a user since 2004.
Kenward
X1 Guru
X1 Guru
 
Posts: 4139
Joined: Tue Apr 20, 2004 2:35 am
Location: UK

Re: 8.3.0.5309: Connection with the x1 service has been lost

Postby Jerald Metz » Tue Nov 04, 2014 5:49 pm

Hey Kenward,

These were Office repairs. Here are instructions for various versions of Office:

First, we recommend exiting out of any X1 and/or Office apps (Menu > Exit) and (File > Exit).

Office 2013

    1. Click Start to access Control Panel > Programs and Features
    2. From the list, select the Microsoft Office 2013 application
    3. Click Change > and either Quick Repair or Online Repair
    4. Follow the remaining onscreen instructions and then allow the repair to complete
    5. After the repair is finished, restart Outlook and X1.

Office 2010

    1. Click Start to access Control Panel > Programs and Features
    2. From the list, select the Microsoft Office 2010 application
    3. Click Change > Repair, then click Continue and follow the prompts
    4. After the repair is finished, restart Outlook and X1.

Outlook 2007

    1. Open Outlook 2007.
    2. Select Help > Office Diagnostics
    3. Click Continue > Run Diagnostics
    4. After running the repair, restart Outlook and X1.

I will also add that PST files are prone to corruption, so running scanPST may yield some benefit for those who are indexing PST files. Steps:

ScanPST

    1. Close X1 and Outlook (make sure there are no X1 or Outlook tasks running
    in the Task Manager)
    2. The Scanpst.exe file is typically located in one of the following folders:

    - C:\Program Files\Common Files\System\MSMAPI\1033
    - C:\Program Files\Common Files\System\Mapi\1033


    3. Double-click on Scanpst.exe to locate and scan your PST file
    4. If any errors are found, allow Scanpst to fix them
Jerald Metz
Product Manager, X1 Search 8

Please feel free to reach me directly at jmetz (at) x1 (dot) com
Jerald Metz
X1 Super User
X1 Super User
 
Posts: 299
Joined: Mon Sep 27, 2004 4:22 pm
Location: Pasadena, CA

Re: 8.3.0.5309: Connection with the x1 service has been lost

Postby Kenward » Wed Nov 05, 2014 3:56 am

I know how Office Repair works. (Although, it is broken on my PC.) My experience has been that scanpst is more effective than Office Repair.
MK
X1 Search 8.6.1 - Build 6003fa (64-bit)
Windows 10 Pro 64-bit | Windows 10 Home 32-bit
No, I have nothing to do with X1, just a user since 2004.
Kenward
X1 Guru
X1 Guru
 
Posts: 4139
Joined: Tue Apr 20, 2004 2:35 am
Location: UK

Re: 8.3.0.5309: Connection with the x1 service has been lost

Postby Jerald Metz » Wed Nov 05, 2014 8:36 am

Kenward,

I am just providing instructions for the benefit of other forum users who may want to try a repair install.

Thanks!
Jerald Metz
Product Manager, X1 Search 8

Please feel free to reach me directly at jmetz (at) x1 (dot) com
Jerald Metz
X1 Super User
X1 Super User
 
Posts: 299
Joined: Mon Sep 27, 2004 4:22 pm
Location: Pasadena, CA

Re: 8.3.0.5309: Connection with the x1 service has been lost

Postby Kenward » Wed Nov 05, 2014 9:08 am

I get that. My question really is what an Office Repair is likely to fix.

One issue could well be that it mends broken MAPI connections. This is what is bugging my installation of Office. (Nothing to do with X1. It just means that I cannot email out of Word.) Would that influence X1?

Fixing a bust PST is more obvious. It is mending a damaged database.
MK
X1 Search 8.6.1 - Build 6003fa (64-bit)
Windows 10 Pro 64-bit | Windows 10 Home 32-bit
No, I have nothing to do with X1, just a user since 2004.
Kenward
X1 Guru
X1 Guru
 
Posts: 4139
Joined: Tue Apr 20, 2004 2:35 am
Location: UK

Re: 8.3.0.5309: Connection with the x1 service has been lost

Postby Jerald Metz » Wed Nov 05, 2014 9:18 am

Well, MAPI is the communication protocol we use with X1, so problems with MAPI could certainly lead to problems with X1.

Running an Office repair restores missing dll files, replaces obviously corrupt dll files, and cleans up some Office registry settings. Problems in any number of those could lead to issues with X1, due to core Outlook corruption, profile issues, or MAPI issues.
Jerald Metz
Product Manager, X1 Search 8

Please feel free to reach me directly at jmetz (at) x1 (dot) com
Jerald Metz
X1 Super User
X1 Super User
 
Posts: 299
Joined: Mon Sep 27, 2004 4:22 pm
Location: Pasadena, CA


Return to Bugs V8

Who is online

Users browsing this forum: No registered users and 15 guests

cron