X1® Professional Client Version 6.7.4

X1® Professional Client Version - Raptor builds (both Beta and Release Candidates)

Moderator: Mods

Re: X1® Professional Client Version 6.7.4

Postby Kenward » Tue Feb 12, 2013 3:38 am

johnix wrote:I would like to know if there are any shortcut (quick way) in Outlook to lookup a contact from the sender on a received e-mail in this version of X1.

Not sure that I understand this one. Are you saying that you want to look up the sender of a found message in Outlook?

If so, if you have a message in the preview pane, right click on the sender's address. If they exist in the Outlook address book, then you can "Edit Contact". If they are not in the address book, then you see different options.

PS When asking a completely new question it might be quicker if you started a new discussion rather than tagged on to the end of a long, old and generic message like this. When there is a flurry of new messages, as there is now, with the new beta, it is all too easy for people to overlook new queries.
X1 Search 8.6.1 - Build 6003fa (64-bit)
Windows 10 Pro 64-bit | Windows 10 Home 32-bit
No, I have nothing to do with X1, just a user since 2004.
X1 Guru
X1 Guru
Posts: 4147
Joined: Tue Apr 20, 2004 2:35 am
Location: UK

Re: X1® Professional Client Version 6.7.4

Postby bobuser » Sat Mar 02, 2013 4:48 pm

For what it's worth, the same happened to me, and this is how I fixed it.

- Installed Office 2013 with click to install - so it ran side-by-side with Office 2010 (just to test out 2013).
- Uninstalled 2013.
- Couldn't see any folders in X1 config when trying to index Outlook. It complained saying no email program is associated with Windows - go to Control Panel to associate it. Outlook 2010 was associated.
- After reading this thread, was going to reinstall Office 2010 - but just did a repair instead. This automatically did the re-association (somehow).
- Happy again.

Still a big fan of X1 - couldn't live without it.

BTW, will be a while till I run 2013, as it doesn't support Exchange 2003 (as you all probably know).
Posts: 35
Joined: Thu Jun 02, 2011 5:17 am

Re: X1® Professional Client Version 6.7.4

Postby Kekkonen » Mon Apr 08, 2013 7:17 am

I have used X1 for several years, and last 12 months X1 has been working perfect with no delays what so ever, lighting fast searches, almost real-time.

Now, I find it very very interesting that recently I was asked to pay for the annual license, naturally, no problem, BUT I opted not to pay for the "support" option that was also attached to this payment. Next thing I know everything slows down and it takes a long time for search results to show up, sometimes 30-60 seconds.

I have re-installed, cleared index file and re-indexed. I have selected for X1 to operate on high-priority in my Win7 ....... no cure.

Is there some sort of fishy business going on ?
Did you guys put me on some slow server because I opted not to pay for this support thing ?
Posts: 2
Joined: Mon Apr 08, 2013 7:10 am

Re: X1® Professional Client Version 6.7.4

Postby Chris Wheaton » Fri Apr 12, 2013 11:41 am

Kekkonen - This is a complete coincidence I assure you.

Chris Wheaton
Technical Support
Customer Care Rep.

Chris Wheaton
X1 Rep
X1 Rep
Posts: 301
Joined: Tue Dec 23, 2008 1:00 pm
Location: Pasadena, CA

Re: X1® Professional Client Version 6.7.4

Postby barclaybrown » Sun Jul 07, 2013 9:56 am

OK, got a work-around to solve this with only Office 2013... here's how.

X1 support is right that the problem is click-to-run. Below I will explain why I believe it is X1 that should fix this.

Here is what I did for the work-around:

1. Uninstall Office 2013 (the click-to-run install that Microsoft did when I bought online).
2. Download and install the Office 2013 Professional Plus evaluation copy (free), which comes as a .img file (just Google to find it on microsoft.com).
3. You can burn this .img file to a DVD or get the free Slysoft Virtual CloneDrive which will mount the .img as a virtual DVD on your PC.
4. Install Office 2013 from this downloaded .img file.
5. When you go to activate it, you can click the option to enter a product key. I entered my paid-for product key for the version of Office 2013 that I bought (doesn't matter that it was a different version of Office 2013, e.g. Home, Student, etc.)
6. I thought I was done, but nooo. It wouldn't activate until I logged into my online Office account (established when I bought Office). When I did, it said that, hey, your Office 2013 is not installed (since I uninstalled it in step 1)
7. With some fear, I went ahead and re-installed the click-to-run version from the Office web site, essentially installing "over" the normally installed evaluation version I installed in step 4.
8. It worked! the click-to-run install did not disturb the already-installed evaluation version. Activation went through and now everything works--X1 and even Rocket-dock (which was confused by the strangely set up click-to-run shortcut icons). (I actually can't tell if the click-to-run installation did anything at all, but doesn't really matter--at least it convinced the Office 2013 web site that I installed Office and allowed me to activate it--in fact I didn't even need to enter the product key--it activated fine via the Office 2013 web site.)

Now, why X1 should fix this, and adapt X1 v 6.7.x to be able to work with a click-to-run installed Office 2013:

1. This is the new way Microsoft is installing Office 2013 and a large majority of Office 2013 will have it installed this way.
2. The new version of X1 does not support Lotus Notes, therefore all Notes users must stay with 6.7.x which means that for these users 6.7.x IS the current version, not an "old" version. Thus the idea that X1 doesn't need to support a new version of Office in an "old" version of X1 does not hold up. By not supporting Office 2013 in 6.7.x, X1 abandons all Notes users who want to stay current on other software like Office. It simply forces X1 users to seek an alternative--I won't mention any here, but just do some searching and you'll find search products that support both Notes and Office 2013.
3. X1 has indicated that they MIGHT support Lotus Notes (which still has many, many thousands of corporate users) but if they delay without supporting Office 2013 in 6.7.x then users can't wait, and will go away and perhaps not return.
4. X1 blaming Microsoft for changing something is silly--things always change in Windows, Office, PC hardware, etc. etc. etc. and makers of software must keep up to stay compatible. X1 cannot simply claim that things must always stay the same for their products to continue to work.
5. Even more comically, the new version of X1 supports Office 2013, so somewhere in the company they must know how to support Office 2013 (even when installed via click-to-run). So why all the mystery about supporting it in 6.7.x?

Hope this is helpful!

Posts: 6
Joined: Sat Aug 20, 2011 12:28 pm

Re: X1® Professional Client Version 6.7.4

Postby ArthurofChicago » Thu Aug 22, 2013 8:43 pm

Just installed 6.7.4 At some point during the Indexing process I receive an error message and all the index is wiped.

Per the instructions I found somewhere on the X1 site, I have modified my Norton antivirus and my Crash Plan back up program to skip/ignore the X1 file yet the farthest I have gotten is to about 25% Index and then total failure.

Any ideas as to what is causing the fail and what solution there is for this problem. I am running a windows 7 machine.

All help appreciated.
Posts: 1
Joined: Thu Aug 22, 2013 8:32 pm

Re: X1® Professional Client Version 6.7.4

Postby dkbulin » Wed Oct 02, 2013 8:42 am

Since I installed 6.7.4, every time I launch Lotus Notes 8.5, the user ID has switched to "oitnsf.id" with a message that it has expired. This file is in c:\program files (x86)\X1\Stellent. I have to switch to my true Notes id every time. I've tried renaming the ID but it appears again the next time I log on. How can I stop Lotus Notes from selecting this ID? I don't find anything in preferences that points to this folder rather than C:\Lotus\Notes\Data.
Posts: 1
Joined: Wed Oct 02, 2013 8:23 am

Re: X1® Professional Client Version 6.7.4

Postby pgomory » Wed Apr 16, 2014 7:28 pm

I have two machines running 6.7.4, both are Windows 7, 32-bit. When I click Check for Updates, I'm told that I already am using the 'latest version." This is odd, since when I bought a third machine this year (also Windows 7) and bought X1, I got the new interface, and today that machine notified me of an update which I installed: "X1 Search 8.2 build 5001dv (64 bit)"

Why can't I updatethe 32-bit machines?
Posts: 3
Joined: Wed Aug 20, 2008 5:18 pm

Re: X1® Professional Client Version 6.7.4

Postby Kenward » Thu Apr 17, 2014 1:34 am

X1 6.7.4 is looking for updates to 6.7.4. There are none.

X1 8.2 is a different program, so much so that it can run side by side with 6.7.4. (That's how I operate, to retain features removed in versions 8.X.)

You have to pay to get 8.X. Some software houses like to bombard users with news of updates that they can buy. So far X1 has not gone down that route.
X1 Search 8.6.1 - Build 6003fa (64-bit)
Windows 10 Pro 64-bit | Windows 10 Home 32-bit
No, I have nothing to do with X1, just a user since 2004.
X1 Guru
X1 Guru
Posts: 4147
Joined: Tue Apr 20, 2004 2:35 am
Location: UK

Re: X1® Professional Client Version 6.7.4

Postby swhx1 » Tue May 27, 2014 1:43 pm

On 6.7.4 but index at a specific time not working. realtime seems to be working. Not clear if that overrides index at a set time. Did not use to on older versions of 6x
Posts: 38
Joined: Tue May 27, 2014 1:40 pm
Location: USA California

Re: X1® Professional Client Version 6.7.4

Postby raytek » Fri Apr 03, 2015 10:18 pm

Cannot add Outlook PST file in X1
Outlook installed on C: Data files on D:
Installed Outlook 2013 from Disc

laptop MSI GT72 2QD Dominator C: is SSD 120GB, D: is 1TB HDD
Running Windows 8
Mail (Microsoft Outlook 2013)(32-bit)
X1 ® Professional Client Version 6.7.4 Build 4054eu) (Created: Wed Jun 6 15:38:39 PDT 2012)
Posts: 6
Joined: Wed Apr 01, 2015 5:00 am

Re: X1® Professional Client Version 6.7.4

Postby gumdoc » Fri Apr 20, 2018 10:38 am

I realize this is a 3-year-old topic but thought I would post my workaround in the hopes it will help others. I run 6.7.4, love it. Tried versions 8+ when they were released, couldn't stand them, so I've always stuck with 6.7.4.

Recently, I decided to wipe my laptop clean and do a fresh install on Windows 10 Pro and Office 2016. Went to install X1 and same problems that others had, it couldn't recognize my OST file, the listing of folders was blank and only allows me to add PST files (I use Exchange with cached mode, no PST files on my system).

So, I downloaded the trial version of 8.6, sure enough, it found and indexed my OST file. Checked on version 6.7.4, list was still blank. Went ahead and deleted the trial version after it ran the index, told it to delete all settings and data and...blam! 6.7.4 now showed all the OST folders. Go figure.

Repeated this on another computer and verified that the workaround is valid. To re-iterate, install 6.7.4, install the trial of the latest version, let it index for awhile, delete the trial and all data, and 6.7.4 will now be able to index the folders. Not sure why it works, just that it does work.

Hope this helps.
Lorne Lavine
Posts: 5
Joined: Sun Apr 06, 2008 8:42 pm

Re: X1® Professional Client Version 6.7.4

Postby gt13 » Sun May 13, 2018 1:10 am


I am using X1 since the origin (I still have an old screen copy of version 2.0 that was free at that time!).
I have been using X1 version 5.2.3 from 2005 to 2018. It worked even with Windows 10 with some adjustments of the parameters.
I kept this version because during many years, following versions of X1 were not able to deal with accented letters in a correct manner.
But version 5.2.3 has some problems (not indexing DOCX, XLSX,... for instance, and hangs from time to time).
I have tested many other software but no other one can compete with X1 as regards ease of use.
So I decided to upgrade.
Since I need Thunderbird support, the last version that I can use is 6.7.4
I checked the trial 14 days version of 6.7.4 and it was perfect for my use. But when I decided to buy it, X1 support said me that they cannot sell it to me anymore. They only sell license codes for version 8, and these license codes are not backward compatible with version 6.7.4.

Is there somebody who has an old license for X1 Professional Client 6, who does not use it anymore, and would accept to sell it to me?
Or perhaps somebody who uses 6.7.4 and would like to upgrade to version 8 (in this case, I could pay him/her the upgrade).

I need a desktop search engine that indexes removable drives, network drives, Thunderbird, image's metadata, Evernote, and works fine with accented letters.
X1 Power User
X1 Power User
Posts: 66
Joined: Sat Apr 17, 2004 10:09 am
Location: France

Re: X1® Professional Client Version 6.7.4

Postby brentg » Thu Jul 19, 2018 1:06 pm

Chris Wheaton wrote:The issue that causes X1 to break is related to how Office2013 - in this pre-release - is distributed. They use something called Office 15 Click-to-Run Extensibility Component.

Click to Run creates some sort of virtual environment wherein your actually running both Outlook2010 and Outlook2013 - and this is why X1 fails.

The solution is to reinstall Office2013 from a "real" install executable and not from the click to run distribution. This link should take you to a stand-alone installer for 2013: https://profile.microsoft.com/RegSysPro ... 033&ci=393

(NOTE: You may have to register to gain access to the install file)

I don't know if you must first remove and then reinstall or exactly what - so you may have to play a little to get this...


Your post above is a very old one, but the problem you (and others) were talking about is a new one for me. Do you know anything new about this issue, or is the only resolve you know of, the same one you recommended above? (i.e. uninstalling/reinstalling Office, etc.)


- Brent
Posts: 1
Joined: Wed Jul 18, 2018 3:08 pm


Return to X1 Professional Client - 6.7.x (Raptor)

Who is online

Users browsing this forum: No registered users and 19 guests